build: drop `trapret` function from non-Linux HOST_TAR variant
[openwrt/openwrt.git] / include / unpack.mk
index 3fabf460336b711a8e413927c901c8a581a7eb46..41ff439242f548671624ec5389f71fb5d61929cf 100644 (file)
@@ -5,12 +5,7 @@
 # See /LICENSE for more information.
 #
 
-# unpacking files with +s may break on some platforms. this typically emits error code 2
-ifneq ($(HOST_OS),Linux)
-  HOST_TAR:=trapret 2 $(TAR)
-else
-  HOST_TAR:=$(TAR)
-endif
+HOST_TAR:=$(TAR)
 TAR_CMD=$(HOST_TAR) -C $(1)/.. $(TAR_OPTIONS)
 UNZIP_CMD=unzip -d $(1)/.. $(DL_DIR)/$(PKG_SOURCE)