change cp to $(CP)
[openwrt/openwrt.git] / openwrt / package / libvorbisidec / Makefile
index 492080b29c02e2f2bf4287c35ddca3b66410803d..d668a0e9b75891ae220e8bb52a91ddad9e936cde 100644 (file)
@@ -1,4 +1,4 @@
-# $Id: Makefile,v 1.2 2005/10/07 17:05:47 nico Exp $
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -62,16 +62,16 @@ $(PKG_BUILD_DIR)/.built:
 
 $(IPKG_LIBVORBISIDEC):
        install -m0755 -d $(IDIR_LIBVORBISIDEC)/usr/lib
-       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libvorbisidec.so.* $(IDIR_LIBVORBISIDEC)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libvorbisidec.so.* $(IDIR_LIBVORBISIDEC)/usr/lib/
        $(RSTRIP) $(IDIR_LIBVORBISIDEC)
        $(IPKG_BUILD) $(IDIR_LIBVORBISIDEC) $(PACKAGE_DIR)
 
 $(STAGING_DIR)/usr/lib/libvorbisidec.so: $(PKG_BUILD_DIR)/.built
        mkdir -p $(STAGING_DIR)/usr/include
-       cp -fpR $(PKG_INSTALL_DIR)/usr/include/tremor $(STAGING_DIR)/usr/include/
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/tremor $(STAGING_DIR)/usr/include/
        mkdir -p $(STAGING_DIR)/usr/lib
-       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libvorbisidec.a $(STAGING_DIR)/usr/lib/
-       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libvorbisidec.so* $(STAGING_DIR)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libvorbisidec.a $(STAGING_DIR)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libvorbisidec.so* $(STAGING_DIR)/usr/lib/
        touch $@
 
 install-dev: $(STAGING_DIR)/usr/lib/libvorbisidec.so