6in4: add netifd support
[openwrt/openwrt.git] / package / 6in4 / Makefile
index fb0803a8a69f724d71c3835dfaf47ffaafddd91b..ee53f5e3cae5c9d25bf39194338a9fa1b633763f 100644 (file)
@@ -34,11 +34,20 @@ endef
 define Build/Configure
 endef
 
-define Package/6in4/install
-       $(INSTALL_DIR) $(1)/lib/network
-       $(INSTALL_DATA) ./files/6in4.sh $(1)/lib/network/6in4.sh
+ifneq ($(CONFIG_PACKAGE_netifd),)
+  define Package/6in4/install
+       $(INSTALL_DIR) $(1)/lib/netifd/proto
+       $(INSTALL_BIN) ./files/6in4.sh $(1)/lib/netifd/proto/6in4.sh
        $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
        $(INSTALL_DATA) ./files/6in4.hotplug $(1)/etc/hotplug.d/iface/90-6in4
-endef
+  endef
+else
+  define Package/6in4/install
+       $(INSTALL_DIR) $(1)/lib/network
+       $(INSTALL_DATA) ./files.old/6in4.sh $(1)/lib/network/6in4.sh
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
+       $(INSTALL_DATA) ./files.old/6in4.hotplug $(1)/etc/hotplug.d/iface/90-6in4
+  endef
+endif
 
 $(eval $(call BuildPackage,6in4))