base-files: drop banner.failsafe if failsafe is disabled
[openwrt/openwrt.git] / package / base-files / Makefile
index fb1267ea5b37ee973289a625b2edb7cba3759010..47d4e73b42a6c8aebd7175c8ab0b963a220e28a6 100644 (file)
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/version.mk
 include $(INCLUDE_DIR)/feeds.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=241
+PKG_RELEASE:=242
 PKG_FLAGS:=nonshared
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
@@ -202,6 +202,9 @@ define Package/base-files/install
                $(VERSION_SED_SCRIPT) $(1)/etc/opkg/distfeeds.conf)
        $(if $(CONFIG_IPK_FILES_CHECKSUMS),, \
                rm -f $(1)/sbin/pkg_check)
+
+       $(if $(CONFIG_TARGET_PREINIT_DISABLE_FAILSAFE), \
+               rm -f $(1)/etc/banner.failsafe,)
 endef
 
 ifneq ($(DUMP),1)