at91: Add SAMA5D27 SOM1 EK board
[openwrt/openwrt.git] / package / boot / at91bootstrap / Makefile
index 8a1ec5e9c917cb79ad5529c0e4ec42434525d6bf..fbe44c424b361b7f904a32cc0a7297e6f8b32112 100644 (file)
@@ -69,6 +69,21 @@ define AT91Bootstrap/sama5d4_xplainedsd_uboot_secure
   BUILD_DEVICES:=at91-sama5d4_xplained
 endef
 
+define AT91Bootstrap/sama5d27_som1_eksd_uboot
+  TITLE:=AT91Bootstrap for SAMA5D27 SOM1 Ek (SDcard0)
+  BUILD_DEVICES:=at91-sama5d27_som1_ek
+endef
+
+define AT91Bootstrap/sama5d27_som1_eksd1_uboot
+  TITLE:=AT91Bootstrap for SAMA5D27 SOM1 Ek (SDcard1)
+  BUILD_DEVICES:=at91-sama5d27_som1_ek
+endef
+
+define AT91Bootstrap/sama5d27_som1_ekqspi_uboot
+  TITLE:=AT91Bootstrap for SAMA5D27 SOM1 Ek (QSPI Flash)
+  BUILD_DEVICES:=at91-sama5d27_som1_ek
+endef
+
 AT91BOOTSTRAP_TARGETS := \
     sama5d2_xplaineddf_uboot \
     sama5d2_xplaineddf_qspi_uboot \
@@ -77,7 +92,9 @@ AT91BOOTSTRAP_TARGETS := \
     sama5d3_xplainedsd_uboot \
     sama5d4_xplainednf_uboot_secure \
     sama5d4_xplaineddf_uboot_secure \
-    sama5d4_xplainedsd_uboot_secure
+    sama5d4_xplainedsd_uboot_secure \
+       sama5d27_som1_eksd_uboot \
+       sama5d27_som1_ekqspi_uboot
 
 define Build/Compile
        +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \