uboot-envtools: Add TARGET_LDFLAGS to fix PIE and RELRO
[openwrt/openwrt.git] / package / boot / uboot-envtools / patches / 001-compile.patch
index 34072f309d3431f8fb1c8cfb0db8789982eab31a..5413aa4a4153836ef9c00e59be680adc54b63c59 100644 (file)
@@ -1,12 +1,15 @@
 --- a/tools/env/Makefile
 +++ b/tools/env/Makefile
-@@ -8,6 +8,10 @@
+@@ -8,6 +8,13 @@
  # with "CC" here for the maximum code reuse of scripts/Makefile.host.
  override HOSTCC = $(CC)
  
 +ifneq ($(TARGET_CFLAGS),)
 +HOSTCFLAGS = $(TARGET_CFLAGS)
 +endif
++ifneq ($(TARGET_LDFLAGS),)
++HOSTLDFLAGS = $(TARGET_LDFLAGS)
++endif
 +
  # Compile for a hosted environment on the target
  HOST_EXTRACFLAGS  = -I$(srctree)/tools \