uboot-envtools: update to 2014.04
[openwrt/openwrt.git] / package / boot / uboot-envtools / patches / 001-compile.patch
diff --git a/package/boot/uboot-envtools/patches/001-compile.patch b/package/boot/uboot-envtools/patches/001-compile.patch
new file mode 100644 (file)
index 0000000..5e038ce
--- /dev/null
@@ -0,0 +1,13 @@
+--- a/tools/env/Makefile
++++ b/tools/env/Makefile
+@@ -10,6 +10,10 @@
+ # with "CC" here for the maximum code reuse of scripts/Makefile.host.
+ HOSTCC = $(CC)
++ifneq ($(TARGET_CFLAGS),)
++HOSTCFLAGS = $(TARGET_CFLAGS)
++endif
++
+ # Compile for a hosted environment on the target
+ HOST_EXTRACFLAGS  = $(patsubst -I%,-idirafter%, $(UBOOTINCLUDE)) \
+               -idirafter $(srctree)/tools/env \