omap: switch from uEnv.txt to generic distro booting
[openwrt/openwrt.git] / package / boot / uboot-omap / Makefile
index b519d6fb80bea90f8941589e3c65bdde4f5b72c1..70c8af1dc4ea2c3c74748fef5afeaf31f2a39b1a 100644 (file)
@@ -19,7 +19,6 @@ include $(INCLUDE_DIR)/package.mk
 define U-Boot/Default
   BUILD_TARGET:=omap
   UBOOT_IMAGE:=u-boot.img MLO
-  UENV:=default
 endef
 
 define U-Boot/omap4_panda
@@ -51,7 +50,8 @@ define Build/InstallDev
                $(CP) $(patsubst %,$(PKG_BUILD_DIR)/%,$(UBOOT_IMAGE)) $(STAGING_DIR_IMAGE)/$(device)/
        )
        $(foreach device,$(BUILD_DEVICES), \
-               $(CP) ./files/uEnv-$(UENV).txt $(STAGING_DIR_IMAGE)/$(device)/uEnv.txt
+               mkimage -C none -A arm -T script -d ./files/boot.scr.txt \
+                       $(STAGING_DIR_IMAGE)/$(device)/boot.scr
        )
 endef