uboot-sunxi: add support for FriendlyARM NanoPi R1S H5
[openwrt/openwrt.git] / package / boot / uboot-sunxi / Makefile
index 9dce3e448a128472983d998dae0eaddf1f56d137..5c27407d155116a9940560ddf30a81812de3cc10 100644 (file)
@@ -270,6 +270,15 @@ define U-Boot/nanopi_neo2
   ATF:=a64
 endef
 
+define U-Boot/nanopi_r1s_h5
+  BUILD_SUBTARGET:=cortexa53
+  NAME:=NanoPi R1S (H5)
+  BUILD_DEVICES:=friendlyarm_nanopi-r1s-h5
+  DEPENDS:=+PACKAGE_u-boot-nanopi_r1s_h5:arm-trusted-firmware-sunxi-a64
+  UENV:=a64
+  ATF:=a64
+endef
+
 define U-Boot/pine64_plus
   BUILD_SUBTARGET:=cortexa53
   NAME:=Pine64 Plus A64
@@ -357,6 +366,7 @@ UBOOT_TARGETS := \
        nanopi_neo_plus2 \
        nanopi_neo2 \
        nanopi_r1 \
+       nanopi_r1s_h5 \
        orangepi_zero \
        orangepi_r1 \
        orangepi_one \