comgt: move 3g hotplug handling to tty subsystem, fixes race on coldplug (#9211)
[openwrt/openwrt.git] / package / comgt / Makefile
index 7c120cb50db8d19f78fc4cdb1cf05b9b600926ab..49cc08bbf123bc5e9bef5fb09dea46ea97ac1fed 100644 (file)
@@ -54,8 +54,8 @@ define Package/comgt/install
        $(INSTALL_DATA) ./files/3g.button $(1)/etc/hotplug.d/button/05-3g
        $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
        $(INSTALL_DATA) ./files/3g.iface $(1)/etc/hotplug.d/iface/05-3g
-       $(INSTALL_DIR) $(1)/etc/hotplug.d/usb
-       $(INSTALL_DATA) ./files/3g.usb $(1)/etc/hotplug.d/usb/30-3g
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/tty
+       $(INSTALL_DATA) ./files/3g.usb $(1)/etc/hotplug.d/tty/30-3g
        $(INSTALL_DIR) $(1)/etc/gcom
        $(INSTALL_DATA) ./files/setpin.gcom $(1)/etc/gcom/setpin.gcom
        $(INSTALL_DATA) ./files/setmode.gcom $(1)/etc/gcom/setmode.gcom