kernel: fix portability issue with perf on linux 5.4
[openwrt/openwrt.git] / package / devel / perf / Makefile
index aa478a04310295a9be292f9376c4919110f063c4..3bb403916bfec892ee917719e05c146660f3a26f 100644 (file)
@@ -36,6 +36,8 @@ define Package/perf/description
   perf is the Linux performance monitoring tool
 endef
 
+HOST_CFLAGS += -I$(LINUX_DIR)/tools/include
+
 MAKE_FLAGS = \
        ARCH="$(LINUX_KARCH)" \
        NO_LIBPERL=1 \
@@ -54,6 +56,7 @@ MAKE_FLAGS = \
        LD="$(TARGET_CROSS)ld" \
        CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
        LDFLAGS="$(TARGET_LDFLAGS)" \
+       KBUILD_HOSTCFLAGS="$(HOST_CFLAGS)" \
        $(if $(findstring c,$(OPENWRT_VERBOSE)),V=1,V='') \
        WERROR=0 \
        O=$(PKG_BUILD_DIR) \