perf: fix build with kernel 4.9
[openwrt/openwrt.git] / package / devel / perf / Makefile
index f2f8d6c95cc2bf2655d8005c2c40fbd3b5077a2e..a9e11b4e3293516e652c181eab6dbd179582ebba 100644 (file)
@@ -61,9 +61,11 @@ MAKE_FLAGS = \
        WERROR=0 \
        prefix=/usr
 
+ifdef CONFIG_LINUX_4_4
 ifdef CONFIG_USE_MUSL
  MAKE_FLAGS += EXTRA_CFLAGS="-I$(CURDIR)/musl-include -include $(CURDIR)/musl-compat.h -D__UCLIBC__"
 endif
+endif
 
 define Build/Compile
        +$(MAKE_FLAGS) $(MAKE) $(PKG_JOBS) \