strace: add option to enable libdw stack tracing
[openwrt/openwrt.git] / package / devel / strace / Makefile
index ded6d3bb843c96b777f83232649f25dbedd9094a..b1e27f22c3d3c9bd545508318598be39573a224b 100644 (file)
@@ -54,12 +54,18 @@ system calls a program makes while it is running.
 endef
 
 define Package/strace/config
+config PACKAGE_strace_libdw
+       bool "Enable stack tracing support using libdw"
+       default n
 config PACKAGE_strace_libunwind
        bool "Enable stack tracing support using libunwind (experimental)"
        default n
 endef
 
-CONFIGURE_ARGS += --with-libunwind=$(if $(CONFIG_PACKAGE_strace_libunwind),yes,no)
+CONFIGURE_ARGS += \
+       --with-libdw=$(if $(CONFIG_PACKAGE_strace_libdw),yes,no) \
+       --with-libunwind=$(if $(CONFIG_PACKAGE_strace_libunwind),yes,no)
+
 MAKE_FLAGS := \
        CCOPT="$(TARGET_CFLAGS)"