ead: fix missing library error while building tinysrp
[openwrt/openwrt.git] / package / ead / src / Makefile
index 0b68f60abe5edd5f16546d3cb80820eb235c40c8..faef3b79972005da46b7b2b2e908349f677df991 100644 (file)
@@ -2,8 +2,8 @@ CC       = gcc
 CPPFLAGS = -I. -Itinysrp
 CFLAGS   = -Os -Wall
 LDFLAGS         =
-LIBS    = tinysrp/libtinysrp.a
-LIBS_EAD = $(LIBS) -lpcap
+LIBS_EADCLIENT = tinysrp/libtinysrp.a
+LIBS_EAD = tinysrp/libtinysrp.a -lpcap
 CONFIGURE_ARGS =
 
 all: ead ead-client
@@ -26,7 +26,7 @@ ead: ead.o $(obj) tinysrp/libtinysrp.a
        $(CC) -o $@ $< $(obj) $(LDFLAGS) $(LIBS_EAD)
 
 ead-client: ead-client.o $(obj)
-       $(CC) -o $@ $< $(obj) $(LDFLAGS) $(LIBS)
+       $(CC) -o $@ $< $(obj) $(LDFLAGS) $(LIBS_EADCLIENT)
 
 clean:
        rm -f *.o ead ead-client