ath10k-firmware: move CT firmwares to new package
[openwrt/openwrt.git] / package / firmware / ath10k-firmware / Makefile
index 6eb7cf9a993068d5f02cc31ef75cf45550a71379..c427f088426528487d839cb57e350708d0375f7e 100644 (file)
@@ -37,11 +37,6 @@ $(Package/ath10k-firmware-default)
   TITLE:=ath10k firmware for QCA9888 devices
 endef
 
-define Package/ath10k-firmware-qca9887-ct
-$(Package/ath10k-firmware-default)
-  TITLE:=ath10k-CT firmware for QCA9887 devices
-endef
-
 define Package/ath10k-firmware-qca988x
 $(Package/ath10k-firmware-default)
   TITLE:=ath10k firmware for QCA988x devices
@@ -49,111 +44,6 @@ $(Package/ath10k-firmware-default)
   CATEGORY:=Firmware
 endef
 
-CT_FIRMWARE_FILE = $(1)-$($(1)_FIRMWARE_FILE_CT)
-CT_FIRMWARE_FILE_HTT = $(1)-$($(1)_FIRMWARE_FILE_CT_HTT)
-
-define Download/ct-firmware
-  URL:=https://www.candelatech.com/downloads/$(2)
-  FILE:=$(call CT_FIRMWARE_FILE,$(1))
-  URL_FILE:=$($(1)_FIRMWARE_FILE_CT)
-endef
-
-define Download/ct-firmware-htt
-  URL:=https://www.candelatech.com/downloads/$(2)
-  FILE:=$(call CT_FIRMWARE_FILE_HTT,$(1))
-  URL_FILE:=$($(1)_FIRMWARE_FILE_CT_HTT)
-endef
-
-QCA988X_FIRMWARE_FILE_CT:=firmware-2-ct-full-community-22.bin.lede.017
-define Download/ath10k-firmware-qca988x-ct
-  $(call Download/ct-firmware,QCA988X,)
-  HASH:=2f0bf766e400a4c5726e77b128eb8c141ebaa778526fe2c7c5083f3b17659dbf
-endef
-$(eval $(call Download,ath10k-firmware-qca988x-ct))
-
-QCA988X_FIRMWARE_FILE_CT_HTT:=firmware-2-ct-full-htt-mgt-community-22.bin.lede.017
-define Download/ath10k-firmware-qca988x-ct-htt
-  $(call Download/ct-firmware-htt,QCA988X,)
-  HASH:=5e4285d5c6eee159a25ca14c6ce26022c32380bd7bafaedfc0c5de1510119007
-endef
-$(eval $(call Download,ath10k-firmware-qca988x-ct-htt))
-
-
-QCA9887_FIRMWARE_FILE_CT:=firmware-2-ct-full-community-22.bin.lede.017
-define Download/ath10k-firmware-qca9887-ct
-  $(call Download/ct-firmware,QCA9887,ath10k-9887)
-  HASH:=4fa30e0e1972ca3b06225a731df0f93a1b73ac67fea5bf54bb55dea3bbc0da6a
-endef
-$(eval $(call Download,ath10k-firmware-qca9887-ct))
-
-QCA9887_FIRMWARE_FILE_CT_HTT:=firmware-2-ct-full-htt-mgt-community-22.bin.lede.017
-define Download/ath10k-firmware-qca9887-ct-htt
-  $(call Download/ct-firmware-htt,QCA9887,ath10k-9887)
-  HASH:=dc681b6b1e45956e7c2e418ab05eee5c943d13e775209196d9bd931ff6493935
-endef
-$(eval $(call Download,ath10k-firmware-qca9887-ct-htt))
-
-
-QCA99X0_FIRMWARE_FILE_CT:=firmware-5-ct-full-community-12.bin-lede.017
-define Download/ath10k-firmware-qca99x0-ct
-  $(call Download/ct-firmware,QCA99X0,ath10k-10-4b)
-  HASH:=289ea845d4bbae6f36b3af2a13a5eaa07097f52d10f7b7306cfc9e2dd394f889
-endef
-$(eval $(call Download,ath10k-firmware-qca99x0-ct))
-
-QCA99X0_FIRMWARE_FILE_CT_HTT:=firmware-5-ct-full-htt-mgt-community-12.bin-lede.017
-define Download/ath10k-firmware-qca99x0-ct-htt
-  $(call Download/ct-firmware-htt,QCA99X0,ath10k-10-4b)
-  HASH:=adedcd3d379a910bc3a5257d75f8970e11319f4cd9c1b34440d35821602a8b9c
-endef
-$(eval $(call Download,ath10k-firmware-qca99x0-ct-htt))
-
-
-QCA9984_FIRMWARE_FILE_CT:=firmware-5-ct-full-community-12.bin-lede.017
-define Download/ath10k-firmware-qca9984-ct
-  $(call Download/ct-firmware,QCA9984,ath10k-9984-10-4b)
-  HASH:=8175be5b3946bddc042be018ff7713e67b41b59374ef4cdd183185b59274c91a
-endef
-$(eval $(call Download,ath10k-firmware-qca9984-ct))
-
-QCA9984_FIRMWARE_FILE_CT_HTT:=firmware-5-ct-full-htt-mgt-community-12.bin-lede.017
-define Download/ath10k-firmware-qca9984-ct-htt
-  $(call Download/ct-firmware-htt,QCA9984,ath10k-9984-10-4b)
-  HASH:=eb8b894cfe0d1aaa87f130bb7fd1815ef07b951c14df8a2ceaeb780df8f640e0
-endef
-$(eval $(call Download,ath10k-firmware-qca9984-ct-htt))
-
-
-QCA4019_FIRMWARE_FILE_CT:=firmware-5-ct-full-community-12.bin-lede.017
-define Download/ath10k-firmware-qca4019-ct
-  $(call Download/ct-firmware,QCA4019,ath10k-4019-10-4b)
-  HASH:=29e9f662c4cd287213877abfbb90fbabb5e32dd3710d3ade82aa94a0921972ae
-endef
-$(eval $(call Download,ath10k-firmware-qca4019-ct))
-
-QCA4019_FIRMWARE_FILE_CT_HTT:=firmware-5-ct-full-htt-mgt-community-12.bin-lede.017
-define Download/ath10k-firmware-qca4019-ct-htt
-  $(call Download/ct-firmware-htt,QCA4019,ath10k-4019-10-4b)
-  HASH:=559c911f23856b1d3d864ce714d1bef7262bf6638e93e057ecf8d5dba48ca1e6
-endef
-$(eval $(call Download,ath10k-firmware-qca4019-ct-htt))
-
-
-QCA9888_FIRMWARE_FILE_CT:=firmware-5-ct-full-community-12.bin-lede.017
-define Download/ath10k-firmware-qca9888-ct
-  $(call Download/ct-firmware,QCA9888,ath10k-9888-10-4b)
-  HASH:=b295880a8b08ec2680d85daaf5f20232a0e73d9cc579bf3efd7ffae24ea340d7
-endef
-$(eval $(call Download,ath10k-firmware-qca9888-ct))
-
-QCA9888_FIRMWARE_FILE_CT_HTT:=firmware-5-ct-full-htt-mgt-community-12.bin-lede.017
-define Download/ath10k-firmware-qca9888-ct-htt
-  $(call Download/ct-firmware-htt,QCA9888,ath10k-9888-10-4b)
-  HASH:=26fe7c00df10e93373a0f9f105e85d02bb8b1cdd629183ce22a5147138336aec
-endef
-$(eval $(call Download,ath10k-firmware-qca9888-ct-htt))
-
-
 define Package/ath10k-firmware-qca99x0
 $(Package/ath10k-firmware-default)
   TITLE:=ath10k firmware for QCA99x0 devices
@@ -161,206 +51,12 @@ $(Package/ath10k-firmware-default)
   CATEGORY:=Firmware
 endef
 
-define Package/ath10k-firmware-qca988x-ct
-$(Package/ath10k-firmware-default)
-  TITLE:=ath10k CT 10.1 firmware for QCA988x devices
-  SECTION:=firmware
-  CATEGORY:=Firmware
-  PROVIDES:=ath10k-firmware-qca988x
-endef
-define Package/ath10k-firmware-qca988x-ct-htt
-$(Package/ath10k-firmware-default)
-  TITLE:=ath10k CT 10.1 htt-mgt fw for QCA988x
-  SECTION:=firmware
-  CATEGORY:=Firmware
-  PROVIDES:=ath10k-firmware-qca988x
-  DEPENDS:=+!PACKAGE_kmod-ath10k-ct-smallbuffers:kmod-ath10k-ct
-endef
-
-define Package/ath10k-firmware-qca9887-ct
-$(Package/ath10k-firmware-default)
-  TITLE:=ath10k CT 10.1 firmware for QCA9887 devices
-  SECTION:=firmware
-  CATEGORY:=Firmware
-  PROVIDES:=ath10k-firmware-qca9887
-endef
-define Package/ath10k-firmware-qca9887-ct-htt
-$(Package/ath10k-firmware-default)
-  TITLE:=ath10k CT 10.1 htt-mgt fw for QCA9887
-  SECTION:=firmware
-  CATEGORY:=Firmware
-  PROVIDES:=ath10k-firmware-qca9887
-  DEPENDS:=+!PACKAGE_kmod-ath10k-ct-smallbuffers:kmod-ath10k-ct
-endef
-
-define Package/ath10k-firmware-qca988x-ct/description
-Alternative ath10k firmware for QCA988X from Candela Technologies.
-Enables IBSS and other features.  See:
-http://www.candelatech.com/ath10k-10.1.php
-This firmware will NOT be used unless the standard ath10k-firmware-qca988x
-is un-selected since the driver will try to load firmware-5.bin before
-firmware-2.bin
-endef
-define Package/ath10k-firmware-qca988x-ct-htt/description
-Alternative ath10k firmware for QCA988X from Candela Technologies.
-Uses normal HTT TX data path for management frames, which improves
-stability in busy networks and fixes .11r authentication.
-Enables IBSS and other features.  See:
-http://www.candelatech.com/ath10k-10.1.php
-This firmware selects and requires the ath10k-ct driver.
-endef
-
-define Package/ath10k-firmware-qca9887-ct/description
-Alternative ath10k firmware for QCA9887 from Candela Technologies.
-Enables IBSS and other features.  See:
-http://www.candelatech.com/ath10k-10.1.php
-This firmware conflicts with the standard 9887 firmware, so select only
-one.
-endef
-define Package/ath10k-firmware-qca9887-ct-htt/description
-Alternative ath10k firmware for QCA9887 from Candela Technologies.
-Uses normal HTT TX data path for management frames, which improves
-stability in busy networks and fixes .11r authentication.
-Enables IBSS and other features.  See:
-http://www.candelatech.com/ath10k-10.1.php
-This firmware selects and requires the ath10k-ct driver.
-endef
-
-define Package/ath10k-firmware-qca99x0-ct/description
-Alternative ath10k firmware for QCA99x0 from Candela Technologies.
-Enables IBSS and other features.  See:
-http://www.candelatech.com/ath10k-10.4.php
-This firmware conflicts with the standard 99x0 firmware, so select only
-one.
-endef
-define Package/ath10k-firmware-qca99x0-ct-htt/description
-Alternative ath10k firmware for QCA99x0 from Candela Technologies.
-Uses normal HTT TX data path for management frames, which improves
-stability in busy networks and may be required for .11r authentication.
-Enables IBSS and other features.  See:
-http://www.candelatech.com/ath10k-10.4.php
-This firmware selects and requires the ath10k-ct driver.
-endef
-
-define Package/ath10k-firmware-qca9984-ct/description
-Alternative ath10k firmware for QCA9984 from Candela Technologies.
-Enables IBSS and other features.  See:
-http://www.candelatech.com/ath10k-10.4.php
-This firmware conflicts with the standard 9984 firmware, so select only
-one.
-endef
-define Package/ath10k-firmware-qca9984-ct-htt/description
-Alternative ath10k firmware for QCA9984 from Candela Technologies.
-Uses normal HTT TX data path for management frames, which improves
-stability in busy networks and may be required for .11r authentication.
-Enables IBSS and other features.  See:
-http://www.candelatech.com/ath10k-10.4.php
-This firmware selects and requires the ath10k-ct driver.
-endef
-
-define Package/ath10k-firmware-qca4019-ct/description
-Alternative ath10k firmware for IPQ4019 radio from Candela Technologies.
-Enables IBSS and other features.  Works with standard or ath10k-ct driver.
-See:  http://www.candelatech.com/ath10k-10.4.php
-endef
-define Package/ath10k-firmware-qca4019-ct-htt/description
-Alternative ath10k firmware for IPQ4019 radio from Candela Technologies.
-Uses normal HTT TX data path for management frames, which improves
-stability in busy networks and may be required for .11r authentication.
-Enables IBSS and other features.
-See:  http://www.candelatech.com/ath10k-10.4.php
-This firmware selects and requires the ath10k-ct driver.
-endef
-
-define Package/ath10k-firmware-qca9888-ct/description
-Alternative ath10k firmware for QCA9886 and QCA9888 from Candela Technologies.
-Enables IBSS and other features.  See:
-http://www.candelatech.com/ath10k-10.4.php
-This firmware conflicts with the standard 9886 and 9888 firmware, so select only
-one.
-endef
-define Package/ath10k-firmware-qca9888-ct-htt/description
-Alternative ath10k firmware for QCA9886 and QCA9888 from Candela Technologies.
-Uses normal HTT TX data path for management frames, which improves
-stability in busy networks and may be required for .11r authentication.
-Enables IBSS and other features.  See:
-http://www.candelatech.com/ath10k-10.4.php
-This firmware selects and requires the ath10k-ct driver.
-endef
-
-
 define Package/ath10k-firmware-qca99x0/description
 Standard ath10k firmware for QCA99x0 from QCA
 This firmware conflicts with the CT 99x0 firmware, so select only
 one.
 endef
 
-define Package/ath10k-firmware-qca99x0-ct
-$(Package/ath10k-firmware-default)
-  TITLE:=ath10k CT 10.4 firmware for QCA99x0 devices
-  SECTION:=firmware
-  CATEGORY:=Firmware
-  PROVIDES:=ath10k-firmware-qca99x0
-endef
-define Package/ath10k-firmware-qca99x0-ct-htt
-$(Package/ath10k-firmware-default)
-  TITLE:=ath10k CT 10.4 htt-mgt fw for QCA99x0
-  SECTION:=firmware
-  CATEGORY:=Firmware
-  PROVIDES:=ath10k-firmware-qca99x0
-  DEPENDS:=+!PACKAGE_kmod-ath10k-ct-smallbuffers:kmod-ath10k-ct
-endef
-
-define Package/ath10k-firmware-qca9984-ct
-$(Package/ath10k-firmware-default)
-  TITLE:=ath10k CT 10.4 firmware for QCA9984 devices
-  SECTION:=firmware
-  CATEGORY:=Firmware
-  PROVIDES:=ath10k-firmware-qca9984
-endef
-define Package/ath10k-firmware-qca9984-ct-htt
-$(Package/ath10k-firmware-default)
-  TITLE:=ath10k CT 10.4 htt-mgt fw for QCA9984
-  SECTION:=firmware
-  CATEGORY:=Firmware
-  PROVIDES:=ath10k-firmware-qca9984
-  DEPENDS:=+!PACKAGE_kmod-ath10k-ct-smallbuffers:kmod-ath10k-ct
-endef
-
-define Package/ath10k-firmware-qca4019-ct
-$(Package/ath10k-firmware-default)
-  TITLE:=ath10k CT 10.4 firmware for QCA4018/9
-  SECTION:=firmware
-  CATEGORY:=Firmware
-  PROVIDES:=ath10k-firmware-qca4019
-endef
-define Package/ath10k-firmware-qca4019-ct-htt
-$(Package/ath10k-firmware-default)
-  TITLE:=ath10k CT 10.4 htt-mgt for QCA4018/9
-  SECTION:=firmware
-  CATEGORY:=Firmware
-  PROVIDES:=ath10k-firmware-qca4019
-  DEPENDS:=+!PACKAGE_kmod-ath10k-ct-smallbuffers:kmod-ath10k-ct
-endef
-
-define Package/ath10k-firmware-qca9888-ct
-$(Package/ath10k-firmware-default)
-  TITLE:=ath10k CT 10.4 fw for QCA9886/8 devices
-  SECTION:=firmware
-  CATEGORY:=Firmware
-  PROVIDES:=ath10k-firmware-qca9888
-endef
-define Package/ath10k-firmware-qca9888-ct-htt
-$(Package/ath10k-firmware-default)
-  TITLE:=ath10k CT 10.4 htt-mgt fw for QCA9886/8
-  SECTION:=firmware
-  CATEGORY:=Firmware
-  PROVIDES:=ath10k-firmware-qca9888
-  DEPENDS:=+!PACKAGE_kmod-ath10k-ct-smallbuffers:kmod-ath10k-ct
-endef
-
-
-
 define Package/ath10k-firmware-qca9984
 $(Package/ath10k-firmware-default)
   TITLE:=ath10k firmware for QCA9984 devices
@@ -477,135 +173,6 @@ define Package/ath10k-firmware-qca9984/install
                $(1)/lib/firmware/ath10k/QCA9984/hw1.0/firmware-5.bin
 endef
 
-
-# CT related firmware
-
-define Package/ath10k-firmware-qca9887-ct/install
-       $(INSTALL_DIR) $(1)/lib/firmware/ath10k/QCA9887/hw1.0
-       $(INSTALL_DATA) \
-               $(DL_DIR)/$(call CT_FIRMWARE_FILE,QCA9887) \
-               $(1)/lib/firmware/ath10k/QCA9887/hw1.0/firmware-2.bin
-       $(INSTALL_DATA) \
-               $(PKG_BUILD_DIR)/QCA9887/hw1.0/board.bin \
-               $(1)/lib/firmware/ath10k/QCA9887/hw1.0/board.bin
-endef
-define Package/ath10k-firmware-qca9887-ct-htt/install
-       $(INSTALL_DIR) $(1)/lib/firmware/ath10k/QCA9887/hw1.0
-       $(INSTALL_DATA) \
-               $(DL_DIR)/$(call CT_FIRMWARE_FILE_HTT,QCA9887) \
-               $(1)/lib/firmware/ath10k/QCA9887/hw1.0/ct-firmware-2.bin
-       $(INSTALL_DATA) \
-               $(PKG_BUILD_DIR)/QCA9887/hw1.0/board.bin \
-               $(1)/lib/firmware/ath10k/QCA9887/hw1.0/board.bin
-endef
-
-define Package/ath10k-firmware-qca988x-ct/install
-       $(INSTALL_DIR) $(1)/lib/firmware/ath10k/QCA988X/hw2.0
-       $(INSTALL_DATA) \
-               $(PKG_BUILD_DIR)/QCA988X/hw2.0/board.bin \
-               $(1)/lib/firmware/ath10k/QCA988X/hw2.0/
-       $(INSTALL_DATA) \
-               $(DL_DIR)/$(call CT_FIRMWARE_FILE,QCA988X) \
-               $(1)/lib/firmware/ath10k/QCA988X/hw2.0/firmware-2.bin
-endef
-define Package/ath10k-firmware-qca988x-ct-htt/install
-       $(INSTALL_DIR) $(1)/lib/firmware/ath10k/QCA988X/hw2.0
-       $(INSTALL_DATA) \
-               $(PKG_BUILD_DIR)/QCA988X/hw2.0/board.bin \
-               $(1)/lib/firmware/ath10k/QCA988X/hw2.0/
-       $(INSTALL_DATA) \
-               $(DL_DIR)/$(call CT_FIRMWARE_FILE_HTT,QCA988X) \
-               $(1)/lib/firmware/ath10k/QCA988X/hw2.0/ct-firmware-2.bin
-endef
-
-define Package/ath10k-firmware-qca99x0-ct/install
-       $(INSTALL_DIR) $(1)/lib/firmware/ath10k/QCA99X0/hw2.0
-       $(INSTALL_DATA) \
-               $(DL_DIR)/$(QCA99X0_BOARD_FILE) \
-               $(1)/lib/firmware/ath10k/QCA99X0/hw2.0/board-2.bin
-       $(INSTALL_DATA) \
-               $(PKG_BUILD_DIR)/QCA99X0/hw2.0/boardData_AR900B_CUS239_5G_v2_001.bin \
-               $(1)/lib/firmware/ath10k/QCA99X0/hw2.0/board.bin
-       $(INSTALL_DATA) \
-               $(DL_DIR)/$(call CT_FIRMWARE_FILE,QCA99X0) \
-               $(1)/lib/firmware/ath10k/QCA99X0/hw2.0/firmware-5.bin
-endef
-define Package/ath10k-firmware-qca99x0-ct-htt/install
-       $(INSTALL_DIR) $(1)/lib/firmware/ath10k/QCA99X0/hw2.0
-       $(INSTALL_DATA) \
-               $(DL_DIR)/$(QCA99X0_BOARD_FILE) \
-               $(1)/lib/firmware/ath10k/QCA99X0/hw2.0/board-2.bin
-       $(INSTALL_DATA) \
-               $(PKG_BUILD_DIR)/QCA99X0/hw2.0/boardData_AR900B_CUS239_5G_v2_001.bin \
-               $(1)/lib/firmware/ath10k/QCA99X0/hw2.0/board.bin
-       $(INSTALL_DATA) \
-               $(DL_DIR)/$(call CT_FIRMWARE_FILE_HTT,QCA99X0) \
-               $(1)/lib/firmware/ath10k/QCA99X0/hw2.0/ct-firmware-5.bin
-endef
-
-define Package/ath10k-firmware-qca9984-ct/install
-       $(INSTALL_DIR) $(1)/lib/firmware/ath10k/QCA9984/hw1.0
-       $(INSTALL_DATA) \
-               $(PKG_BUILD_DIR)/QCA9984/hw1.0/board-2.bin \
-               $(1)/lib/firmware/ath10k/QCA9984/hw1.0/board-2.bin
-       $(INSTALL_DATA) \
-               $(DL_DIR)/$(call CT_FIRMWARE_FILE,QCA9984) \
-               $(1)/lib/firmware/ath10k/QCA9984/hw1.0/firmware-5.bin
-endef
-define Package/ath10k-firmware-qca9984-ct-htt/install
-       $(INSTALL_DIR) $(1)/lib/firmware/ath10k/QCA9984/hw1.0
-       $(INSTALL_DATA) \
-               $(PKG_BUILD_DIR)/QCA9984/hw1.0/board-2.bin \
-               $(1)/lib/firmware/ath10k/QCA9984/hw1.0/board-2.bin
-       $(INSTALL_DATA) \
-               $(DL_DIR)/$(call CT_FIRMWARE_FILE_HTT,QCA9984) \
-               $(1)/lib/firmware/ath10k/QCA9984/hw1.0/ct-firmware-5.bin
-endef
-
-define Package/ath10k-firmware-qca4019-ct/install
-       $(INSTALL_DIR) $(1)/lib/firmware/ath10k/QCA4019/hw1.0
-       $(INSTALL_DATA) \
-               $(PKG_BUILD_DIR)/QCA4019/hw1.0/board-2.bin \
-               $(1)/lib/firmware/ath10k/QCA4019/hw1.0/
-       $(INSTALL_DATA) \
-               $(DL_DIR)/$(call CT_FIRMWARE_FILE,QCA4019) \
-               $(1)/lib/firmware/ath10k/QCA4019/hw1.0/firmware-5.bin
-endef
-define Package/ath10k-firmware-qca4019-ct-htt/install
-       $(INSTALL_DIR) $(1)/lib/firmware/ath10k/QCA4019/hw1.0
-       $(INSTALL_DATA) \
-               $(PKG_BUILD_DIR)/QCA4019/hw1.0/board-2.bin \
-               $(1)/lib/firmware/ath10k/QCA4019/hw1.0/
-       $(INSTALL_DATA) \
-               $(DL_DIR)/$(call CT_FIRMWARE_FILE_HTT,QCA4019) \
-               $(1)/lib/firmware/ath10k/QCA4019/hw1.0/ct-firmware-5.bin
-endef
-
-define Package/ath10k-firmware-qca9888-ct/install
-       $(INSTALL_DIR) $(1)/lib/firmware/ath10k/QCA9888/hw2.0
-       ln -s \
-               ../../cal-pci-0000:01:00.0.bin \
-               $(1)/lib/firmware/ath10k/QCA9888/hw2.0/board.bin
-       $(INSTALL_DATA) \
-               $(PKG_BUILD_DIR)/QCA9888/hw2.0/board-2.bin \
-               $(1)/lib/firmware/ath10k/QCA9888/hw2.0/board-2.bin
-       $(INSTALL_DATA) \
-               $(DL_DIR)/$(call CT_FIRMWARE_FILE,QCA9888) \
-               $(1)/lib/firmware/ath10k/QCA9888/hw2.0/firmware-5.bin
-endef
-define Package/ath10k-firmware-qca9888-ct-htt/install
-       $(INSTALL_DIR) $(1)/lib/firmware/ath10k/QCA9888/hw2.0
-       ln -s \
-               ../../cal-pci-0000:01:00.0.bin \
-               $(1)/lib/firmware/ath10k/QCA9888/hw2.0/board.bin
-       $(INSTALL_DATA) \
-               $(PKG_BUILD_DIR)/QCA9888/hw2.0/board-2.bin \
-               $(1)/lib/firmware/ath10k/QCA9888/hw2.0/board-2.bin
-       $(INSTALL_DATA) \
-               $(DL_DIR)/$(call CT_FIRMWARE_FILE_HTT,QCA9888) \
-               $(1)/lib/firmware/ath10k/QCA9888/hw2.0/ct-firmware-5.bin
-endef
-
 $(eval $(call BuildPackage,ath10k-firmware-qca9887))
 #$(eval $(call BuildPackage,ath10k-firmware-qca9888))
 $(eval $(call BuildPackage,ath10k-firmware-qca988x))
@@ -613,16 +180,3 @@ $(eval $(call BuildPackage,ath10k-firmware-qca988x))
 #$(eval $(call BuildPackage,ath10k-firmware-qca6174))
 #$(eval $(call BuildPackage,ath10k-firmware-qca9984))
 #$(eval $(call BuildPackage,ath10k-firmware-qca4019))
-
-$(eval $(call BuildPackage,ath10k-firmware-qca9887-ct))
-$(eval $(call BuildPackage,ath10k-firmware-qca9887-ct-htt))
-$(eval $(call BuildPackage,ath10k-firmware-qca988x-ct))
-$(eval $(call BuildPackage,ath10k-firmware-qca988x-ct-htt))
-$(eval $(call BuildPackage,ath10k-firmware-qca99x0-ct))
-$(eval $(call BuildPackage,ath10k-firmware-qca99x0-ct-htt))
-$(eval $(call BuildPackage,ath10k-firmware-qca9984-ct))
-$(eval $(call BuildPackage,ath10k-firmware-qca9984-ct-htt))
-$(eval $(call BuildPackage,ath10k-firmware-qca4019-ct))
-$(eval $(call BuildPackage,ath10k-firmware-qca4019-ct-htt))
-$(eval $(call BuildPackage,ath10k-firmware-qca9888-ct))
-$(eval $(call BuildPackage,ath10k-firmware-qca9888-ct-htt))