ath10k-ct: adds leds support
[openwrt/openwrt.git] / package / kernel / ath10k-ct / Makefile
index 366515189a13f2f0d6c54c7941f0b4e999c98606..d39ecabf462e6c57672642a1e047809135934e2c 100644 (file)
@@ -37,6 +37,14 @@ define KernelPackage/ath10k-ct
   PROVIDES:=kmod-ath10k
 endef
 
   PROVIDES:=kmod-ath10k
 endef
 
+define KernelPackage/ath10k-ct/config
+
+       config ATH10K-CT_LEDS
+               bool "Enable LED support"
+               default y
+               depends on PACKAGE_kmod-ath10k-ct
+endef
+
 NOSTDINC_FLAGS = \
        -I$(PKG_BUILD_DIR) \
        -I$(STAGING_DIR)/usr/include/mac80211-backport/uapi \
 NOSTDINC_FLAGS = \
        -I$(PKG_BUILD_DIR) \
        -I$(STAGING_DIR)/usr/include/mac80211-backport/uapi \
@@ -77,6 +85,11 @@ ifdef CONFIG_PACKAGE_ATH_SPECTRAL
   NOSTDINC_FLAGS += -DCONFIG_ATH10K_SPECTRAL
 endif
 
   NOSTDINC_FLAGS += -DCONFIG_ATH10K_SPECTRAL
 endif
 
+ifeq ($(CONFIG_ATH10K-CT_LEDS),y)
+  CT_MAKEDEFS += CONFIG_ATH10K_LEDS=y
+  NOSTDINC_FLAGS += -DCONFIG_ATH10K_LEDS
+endif
+
 define Build/Configure
        cp $(STAGING_DIR)/usr/include/mac80211/ath/*.h $(PKG_BUILD_DIR)
 endef
 define Build/Configure
        cp $(STAGING_DIR)/usr/include/mac80211/ath/*.h $(PKG_BUILD_DIR)
 endef