ltq-ifxos: fix broken autoconf invocation
[openwrt/openwrt.git] / package / kernel / lantiq / ltq-ifxos / Makefile
index 0a0fc9a2478600ac781519076efd1c043e387a8f..375875227e6ad1c7c88bf9c1a13d0c6c773b9193 100644 (file)
@@ -15,6 +15,7 @@ PKG_MD5SUM:=bc107f9d8ff6bed4c2760a2817bbb029
 PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
 
 PKG_USE_MIPS16:=0
+PKG_FIXUP:=autoreconf
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -36,11 +37,6 @@ CONFIGURE_ARGS += \
        --enable-kernelincl="$(LINUX_DIR)/include" \
        --enable-add_drv_cflags="-fno-pic -mno-abicalls -mlong-calls -G 0"
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); aclocal && autoconf && automake)
-       $(call Build/Configure/Default)
-endef
-
 ifdef CONFIG_TARGET_lantiq
   define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/{lib,include/ifxos}