kernel: modules: add missing kmod-mdio-devres for lan743x
[openwrt/openwrt.git] / package / kernel / linux / modules / netdevices.mk
index 6ab797de949b51a8c9b1f74d1b2b2a5480fa045c..2af84be638232b40e69ba8cc539fe64bc92b526f 100644 (file)
@@ -1527,7 +1527,7 @@ $(eval $(call KernelPackage,atlantic))
 define KernelPackage/lan743x
   SUBMENU:=$(NETWORK_DEVICES_MENU)
   TITLE:=Microchip LAN743x PCI Express Gigabit Ethernet NIC
-  DEPENDS:=@PCI_SUPPORT +kmod-ptp
+  DEPENDS:=@PCI_SUPPORT +kmod-ptp +kmod-mdio-devres
   KCONFIG:=CONFIG_LAN743X
   FILES:=$(LINUX_DIR)/drivers/net/ethernet/microchip/lan743x.ko
   AUTOLOAD:=$(call AutoProbe,lan743x)