mac80211: enable ATH9K_HWRNG
[openwrt/openwrt.git] / package / kernel / mac80211 / ath.mk
index 4f14fec8e26e9403bf88619ffcd6876d1fe52dc9..dc08df4f6fec566a460a5b3b7f4f6ee7fcb8af16 100644 (file)
@@ -225,7 +225,7 @@ define KernelPackage/ath9k/config
                bool "Add wireless noise as source of randomness to kernel entropy pool"
                depends on PACKAGE_kmod-ath9k
                select PACKAGE_kmod-random-core
-               default n
+               default y
 
        config ATH9K_SUPPORT_PCOEM
                bool "Support chips used in PC OEM cards"
@@ -377,7 +377,7 @@ endef
 define KernelPackage/ar5523
   $(call KernelPackage/mac80211/Default)
   TITLE:=Driver for Atheros AR5523 USB sticks
-  DEPENDS:=@USB_SUPPORT +kmod-mac80211 +kmod-ath +kmod-usb-core +kmod-input-core 
+  DEPENDS:=@USB_SUPPORT +kmod-mac80211 +kmod-ath +kmod-usb-core +kmod-input-core
   FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/ath/ar5523/ar5523.ko
   AUTOLOAD:=$(call AutoProbe,ar5523)
 endef