fix keynote compile
[openwrt/openwrt.git] / package / keynote / Makefile
index 5b27257b4a74ddb3831210a5fea861f381f3d3af..56bbeb0e5849842765c73295e63c6cdb4832795a 100644 (file)
@@ -40,6 +40,8 @@ CONFIGURE_ARGS += \
 MAKE_FLAGS += \
        CFLAGS="$(TARGET_CFLAGS)"
 
+TARGET_CFLAGS += -Dbcopy=memmove -Dindex\(s,c\)=strchr\(s,c\)
+
 define Build/InstallDev
        mkdir -p $(1)/usr/include/keynote
        $(CP) $(PKG_BUILD_DIR)/{assertion,header,keynote,signature}.h $(1)/usr/include/keynote/