pass the CFLAGS through the environment on compile and fix a few packages
[openwrt/openwrt.git] / package / keynote / Makefile
index 579300407bc7edc94b3942ee88a1a11c357afcc7..ed4d4f020b8d384dab4ea5a27586f9520a24b62d 100644 (file)
@@ -42,11 +42,7 @@ define Build/Configure
        )
 endef
 
-define Build/Compile
-       $(call Build/Compile/Default, \
-               CFLAGS="\$$$$(EXTRA_CFLAGS) \$$$$(EXTRA_LDFLAGS)" \
-       )
-endef
+EXTRA_CFLAGS += $(EXTRA_LDFLAGS)
 
 define Build/InstallDev
        mkdir -p $(STAGING_DIR)/usr/include