treewide: add support for "gc-sections" in PKG_BUILD_FLAGS
[openwrt/openwrt.git] / package / libs / libnl / Makefile
index 71b043a9e565073dba118b7c838d6c2a8e73c3d6..56549dcc0a24a2dea0b3e28418178ea4dbaa0b3d 100644 (file)
@@ -20,6 +20,8 @@ PKG_CPE_ID:=cpe:/a:libnl_project:libnl
 PKG_INSTALL:=1
 PKG_FIXUP:=autoreconf
 
+PKG_BUILD_FLAGS:=gc-sections
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libnl/default
@@ -80,7 +82,7 @@ define Package/libnl/description
  message construction and parsing, object caching system, etc.
 endef
 
-TARGET_CFLAGS += -ffunction-sections -fdata-sections $(FPIC)
+TARGET_CFLAGS += $(FPIC)
 
 CONFIGURE_ARGS += \
        --disable-debug