libs/libnl: Update to 3.3.0
[openwrt/openwrt.git] / package / libs / libnl / Makefile
index 7916556c00ef412c80065cbd6f41bb831f6d7fb6..67201cc7cc66394b75ad449c4978b5f1b2800c79 100644 (file)
@@ -8,14 +8,17 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libnl
-PKG_VERSION:=3.2.29
+PKG_VERSION:=3.3.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://github.com/thom311/libnl/releases/download/libnl3_2_29
-PKG_HASH:=0beb593dc6abfffa18a5c787b27884979c1b7e7f1fd468c801e3cc938a685922
+PKG_SOURCE_URL:=https://github.com/thom311/libnl/releases/download/libnl3_3_0
+PKG_HASH:=705468b5ae4cd1eb099d2d1c476d6a3abe519bc2810becf12fb1e32de1e074e4
 PKG_LICENSE:=LGPL-2.1
 
+PKG_INSTALL:=1
+PKG_FIXUP:=autoreconf
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libnl/default
@@ -77,13 +80,6 @@ endef
 
 TARGET_CFLAGS += -ffunction-sections $(FPIC)
 
-define Build/Compile
-       $(call Build/Compile/Default)
-       make -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               install
-endef
-
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/libnl3 $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/include/libnl3/* $(1)/usr/include/libnl3/