libmbedtls: use defaults if no build opts selected
[openwrt/openwrt.git] / package / libs / mbedtls / Makefile
index a489f56755ed0257f2af7bf02a956f26b4fb1a55..fd0f821d85823886157f87d4970043a213e218f4 100644 (file)
@@ -140,10 +140,11 @@ endef
 define Build/Prepare
        $(call Build/Prepare/Default)
 
-       $(foreach opt,$(MBEDTLS_BUILD_OPTS),
+       $(if $(strip $(foreach opt,$(MBEDTLS_BUILD_OPTS),$($(opt)))),
+        $(foreach opt,$(MBEDTLS_BUILD_OPTS),
         $(PKG_BUILD_DIR)/scripts/config.py \
         -f $(PKG_BUILD_DIR)/include/mbedtls/config.h \
-        $(if $($(opt)),set,unset) $(patsubst CONFIG_%,%,$(opt)))
+        $(if $($(opt)),set,unset) $(patsubst CONFIG_%,%,$(opt))),)
 endef
 
 define Build/InstallDev