polarssl: Fix build failures due to PKG_NAME != dir name
[openwrt/openwrt.git] / package / libs / polarssl / Makefile
index c7e603623a8679f9e20cdcc5f213ccafa170c294..5d5e8576589cc94ca452618c283aa6438b0641bb 100644 (file)
@@ -7,15 +7,18 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_NAME:=mbedtls
+PKG_NAME:=polarssl
+SRC_PKG_NAME:=mbedtls
 PKG_VERSION:=1.3.11
 PKG_RELEASE:=2
 PKG_USE_MIPS16:=0
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-gpl.tgz
+PKG_SOURCE:=$(SRC_PKG_NAME)-$(PKG_VERSION)-gpl.tgz
 PKG_SOURCE_URL:=https://polarssl.org/download/
 PKG_MD5SUM:=c02ce2e54862d678604794ee484fb59e
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(SRC_PKG_NAME)-$(PKG_VERSION)
+
 PKG_BUILD_PARALLEL:=1
 PKG_LICENSE:=GPL-2.0+