lua: use float instead of double, reduces the gc data structure size by 4 byte =...
[openwrt/openwrt.git] / package / lua / Makefile
index b418b303efeff4fb1171eeaebdebc61005d09d04..4589cfed2cffadb37a08f00f0f5e901918d0f9d6 100644 (file)
@@ -83,7 +83,7 @@ endef
 define Build/Configure
 endef
 
-TARGET_CFLAGS += -DLUA_USE_LINUX $(FPIC)
+TARGET_CFLAGS += -DLUA_USE_LINUX $(FPIC) -std=gnu99
 
 ifneq ($(CONFIG_USE_EGLIBC),)
   ifeq ($(CONFIG_EGLIBC_OPTION_EGLIBC_UTMP),)