mac80211: update to wireless-testing 2012-05-29
[openwrt/openwrt.git] / package / mac80211 / patches / 007-remove_misc_drivers.patch
index 99cfe73b69306507b72a7493a44bf406b65fe24d..f5bd351a4033fe56b99344279ac9647adda9e67a 100644 (file)
@@ -1,6 +1,6 @@
 --- a/config.mk
 +++ b/config.mk
-@@ -237,7 +237,7 @@ $(warning "WARNING: CONFIG_CFG80211_WEXT
+@@ -240,7 +240,7 @@ $(warning "WARNING: CONFIG_CFG80211_WEXT
  endif #CONFIG_WIRELESS_EXT
  
  ifdef CONFIG_STAGING
@@ -9,7 +9,7 @@
  endif #CONFIG_STAGING
  
  # mac80211 test driver
-@@ -391,15 +391,15 @@ endif #CONFIG_CRC_ITU_T
+@@ -399,15 +399,15 @@ endif #CONFIG_CRC_ITU_T
  export CONFIG_MWL8K=m
  
  # Ethernet drivers go here
 +# export CONFIG_ATL1=m
 +# export CONFIG_ATL2=m
 +# export CONFIG_ATL1E=m
- ifdef CONFIG_COMPAT_KERNEL_2_6_27
+ ifdef CONFIG_COMPAT_KERNEL_2_6_28
+-export CONFIG_ATL1C=m
+-export CONFIG_ALX=n
++# export CONFIG_ATL1C=m
++# export CONFIG_ALX=n
+ else #CONFIG_COMPAT_KERNEL_2_6_28
 -export CONFIG_ATL1C=n
 -export CONFIG_ALX=m
 +# export CONFIG_ATL1C=n
 +# export CONFIG_ALX=m
- else #CONFIG_COMPAT_KERNEL_2_6_27
--export CONFIG_ATL1C=n
--export CONFIG_ALX=m
-+# export CONFIG_ATL1C=n
-+# export CONFIG_ALX=m
- endif #CONFIG_COMPAT_KERNEL_2_6_27
+ endif #CONFIG_COMPAT_KERNEL_2_6_28
  
  ifdef CONFIG_WIRELESS_EXT
-@@ -460,21 +460,21 @@ endif #CONFIG_COMPAT_KERNEL_2_6_29
+@@ -468,21 +468,21 @@ endif #CONFIG_COMPAT_KERNEL_2_6_29
  # Note: this depends on CONFIG_USB_NET_RNDIS_HOST and CONFIG_USB_NET_CDCETHER
  # it also requires new RNDIS_HOST and CDC_ETHER modules which we add
  ifdef CONFIG_COMPAT_KERNEL_2_6_29