refresh madwifi patches
[openwrt/openwrt.git] / package / madwifi / patches / 102-multicall_binary.patch
index 3b31f0e2c9b7d0fffda7be2c16943b189e77a77d..bd31d96576db44535ae8fdfee822aa02c381e9dd 100644 (file)
@@ -1,7 +1,7 @@
 Index: madwifi-ng-r2568-20070710/tools/80211debug.c
 ===================================================================
---- madwifi-ng-r2568-20070710.orig/tools/80211debug.c  2007-07-13 11:18:14.513123601 +0200
-+++ madwifi-ng-r2568-20070710/tools/80211debug.c       2007-07-13 11:18:15.097156885 +0200
+--- madwifi-ng-r2568-20070710.orig/tools/80211debug.c  2007-07-23 01:48:38.846193887 +0200
++++ madwifi-ng-r2568-20070710/tools/80211debug.c       2007-07-23 01:48:39.578235605 +0200
 @@ -49,6 +49,10 @@
  #include <getopt.h>
  #include <err.h>
@@ -35,8 +35,8 @@ Index: madwifi-ng-r2568-20070710/tools/80211debug.c
        const char *sep;
 Index: madwifi-ng-r2568-20070710/tools/80211stats.c
 ===================================================================
---- madwifi-ng-r2568-20070710.orig/tools/80211stats.c  2007-07-13 11:18:14.517123827 +0200
-+++ madwifi-ng-r2568-20070710/tools/80211stats.c       2007-07-13 11:18:15.101157110 +0200
+--- madwifi-ng-r2568-20070710.orig/tools/80211stats.c  2007-07-23 01:48:38.854194346 +0200
++++ madwifi-ng-r2568-20070710/tools/80211stats.c       2007-07-23 01:48:39.578235605 +0200
 @@ -60,6 +60,10 @@
  #include "net80211/ieee80211_crypto.h"
  #include "net80211/ieee80211_ioctl.h"
@@ -70,8 +70,8 @@ Index: madwifi-ng-r2568-20070710/tools/80211stats.c
        u_int8_t buf[24*1024], *cp;
 Index: madwifi-ng-r2568-20070710/tools/athchans.c
 ===================================================================
---- madwifi-ng-r2568-20070710.orig/tools/athchans.c    2007-07-13 11:18:14.525124286 +0200
-+++ madwifi-ng-r2568-20070710/tools/athchans.c 2007-07-13 11:18:15.121158252 +0200
+--- madwifi-ng-r2568-20070710.orig/tools/athchans.c    2007-07-23 01:48:38.858194572 +0200
++++ madwifi-ng-r2568-20070710/tools/athchans.c 2007-07-23 01:48:39.598236745 +0200
 @@ -59,6 +59,10 @@
  #include "net80211/ieee80211_crypto.h"
  #include "net80211/ieee80211_ioctl.h"
@@ -106,8 +106,8 @@ Index: madwifi-ng-r2568-20070710/tools/athchans.c
        int c;
 Index: madwifi-ng-r2568-20070710/tools/athctrl.c
 ===================================================================
---- madwifi-ng-r2568-20070710.orig/tools/athctrl.c     2007-07-13 11:18:14.533124742 +0200
-+++ madwifi-ng-r2568-20070710/tools/athctrl.c  2007-07-13 11:18:15.149159848 +0200
+--- madwifi-ng-r2568-20070710.orig/tools/athctrl.c     2007-07-23 01:48:38.866195027 +0200
++++ madwifi-ng-r2568-20070710/tools/athctrl.c  2007-07-23 01:48:39.626238340 +0200
 @@ -53,6 +53,10 @@
  
  #include <net/if.h>
@@ -141,8 +141,8 @@ Index: madwifi-ng-r2568-20070710/tools/athctrl.c
        int c;
 Index: madwifi-ng-r2568-20070710/tools/athdebug.c
 ===================================================================
---- madwifi-ng-r2568-20070710.orig/tools/athdebug.c    2007-07-13 11:18:14.537124968 +0200
-+++ madwifi-ng-r2568-20070710/tools/athdebug.c 2007-07-13 11:18:15.169160989 +0200
+--- madwifi-ng-r2568-20070710.orig/tools/athdebug.c    2007-07-23 01:48:38.874195486 +0200
++++ madwifi-ng-r2568-20070710/tools/athdebug.c 2007-07-23 01:48:39.650239706 +0200
 @@ -52,6 +52,10 @@
  #include <getopt.h>
  #include <err.h>
@@ -177,8 +177,8 @@ Index: madwifi-ng-r2568-20070710/tools/athdebug.c
  #else
 Index: madwifi-ng-r2568-20070710/tools/athkey.c
 ===================================================================
---- madwifi-ng-r2568-20070710.orig/tools/athkey.c      2007-07-13 11:18:14.545125427 +0200
-+++ madwifi-ng-r2568-20070710/tools/athkey.c   2007-07-13 11:18:15.197162582 +0200
+--- madwifi-ng-r2568-20070710.orig/tools/athkey.c      2007-07-23 01:48:38.878195712 +0200
++++ madwifi-ng-r2568-20070710/tools/athkey.c   2007-07-23 01:48:39.698242443 +0200
 @@ -59,6 +59,10 @@
  #include "net80211/ieee80211_crypto.h"
  #include "net80211/ieee80211_ioctl.h"
@@ -212,8 +212,8 @@ Index: madwifi-ng-r2568-20070710/tools/athkey.c
        struct ieee80211req_del_key delkey;
 Index: madwifi-ng-r2568-20070710/tools/athstats.c
 ===================================================================
---- madwifi-ng-r2568-20070710.orig/tools/athstats.c    2007-07-13 11:18:14.553125879 +0200
-+++ madwifi-ng-r2568-20070710/tools/athstats.c 2007-07-13 11:18:15.237164863 +0200
+--- madwifi-ng-r2568-20070710.orig/tools/athstats.c    2007-07-23 01:48:38.886196167 +0200
++++ madwifi-ng-r2568-20070710/tools/athstats.c 2007-07-23 01:48:39.726244040 +0200
 @@ -63,6 +63,10 @@
  #include "wireless_copy.h"
  #include "if_athioctl.h"
@@ -249,7 +249,7 @@ Index: madwifi-ng-r2568-20070710/tools/athstats.c
 Index: madwifi-ng-r2568-20070710/tools/do_multi.c
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ madwifi-ng-r2568-20070710/tools/do_multi.c 2007-07-13 11:18:15.265166457 +0200
++++ madwifi-ng-r2568-20070710/tools/do_multi.c 2007-07-23 01:48:39.754245634 +0200
 @@ -0,0 +1,30 @@
 +#include <string.h>
 +#include "do_multi.h"
@@ -278,13 +278,13 @@ Index: madwifi-ng-r2568-20070710/tools/do_multi.c
 +      ret =  athstats_init(argc, argv);
 +    if(strcmp(progname, "wlanconfig") == 0)
 +      ret =  wlanconfig_init(argc, argv);
-+    
++
 +    return ret;
 +}
 Index: madwifi-ng-r2568-20070710/tools/do_multi.h
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ madwifi-ng-r2568-20070710/tools/do_multi.h 2007-07-13 11:18:15.293168054 +0200
++++ madwifi-ng-r2568-20070710/tools/do_multi.h 2007-07-23 01:48:39.778247001 +0200
 @@ -0,0 +1,9 @@
 +
 +int a80211debug_init(int argc, char *argv[]);
@@ -297,8 +297,8 @@ Index: madwifi-ng-r2568-20070710/tools/do_multi.h
 +int wlanconfig_init(int argc, char *argv[]);
 Index: madwifi-ng-r2568-20070710/tools/Makefile
 ===================================================================
---- madwifi-ng-r2568-20070710.orig/tools/Makefile      2007-07-13 11:18:14.569126791 +0200
-+++ madwifi-ng-r2568-20070710/tools/Makefile   2007-07-13 11:18:15.313169194 +0200
+--- madwifi-ng-r2568-20070710.orig/tools/Makefile      2007-07-23 01:48:38.902197078 +0200
++++ madwifi-ng-r2568-20070710/tools/Makefile   2007-07-23 01:48:39.798248141 +0200
 @@ -49,6 +49,12 @@
  
  ALL=  athstats 80211stats athkey athchans athctrl \
@@ -306,7 +306,7 @@ Index: madwifi-ng-r2568-20070710/tools/Makefile
 +      
 +ifdef DOMULTI
 +OBJS= do_multi.o athstats.o 80211stats.o athkey.o athchans.o athctrl.o \
-+      athdebug.o 80211debug.o wlanconfig.o 
++      athdebug.o 80211debug.o wlanconfig.o
 +ALL=  ${OBJS} madwifi_multi
 +endif
  
@@ -345,8 +345,8 @@ Index: madwifi-ng-r2568-20070710/tools/Makefile
  80211stats: 80211stats.c
 Index: madwifi-ng-r2568-20070710/tools/wlanconfig.c
 ===================================================================
---- madwifi-ng-r2568-20070710.orig/tools/wlanconfig.c  2007-07-13 11:18:14.577127250 +0200
-+++ madwifi-ng-r2568-20070710/tools/wlanconfig.c       2007-07-13 11:18:15.337170561 +0200
+--- madwifi-ng-r2568-20070710.orig/tools/wlanconfig.c  2007-07-23 01:48:38.910197536 +0200
++++ madwifi-ng-r2568-20070710/tools/wlanconfig.c       2007-07-23 01:48:39.850251108 +0200
 @@ -62,6 +62,10 @@
  #include "net80211/ieee80211_crypto.h"
  #include "net80211/ieee80211_ioctl.h"