ltq-vdsl-app: use notification based ATM/PTM driver load
[openwrt/openwrt.git] / package / network / config / ltq-vdsl-app / Makefile
index 815f89c0b8ad8250d82393d7f47e8779f4d72380..20b506c48e079d708f27b00aeac298e0e769bd4e 100644 (file)
@@ -58,9 +58,10 @@ CONFIGURE_ARGS += \
 #CONFIGURE_ARGS += --enable-model=debug
 
 define Package/ltq-vdsl-app/install
-       $(INSTALL_DIR) $(1)/etc/init.d $(1)/sbin
+       $(INSTALL_DIR) $(1)/etc/init.d $(1)/sbin $(1)/etc/hotplug.d/dsl
        $(INSTALL_BIN) ./files/dsl_control $(1)/etc/init.d/
-       $(INSTALL_BIN) ./files/vdsl_cpe_control_wrapper $(1)/sbin/
+       $(INSTALL_BIN) ./files/10_atm.sh $(1)/etc/hotplug.d/dsl
+       $(INSTALL_BIN) ./files/10_ptm.sh $(1)/etc/hotplug.d/dsl
 
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/dsl_cpe_control $(1)/sbin/vdsl_cpe_control
        $(INSTALL_BIN) ./files/dsl_cpe_pipe.sh $(1)/sbin/