swconfig: replace the shared library with a static one
[openwrt/openwrt.git] / package / network / config / swconfig / src / Makefile
index 1176bf0e40035db5a5af11072f8632dffc89bcb9..e972a4439771cee023071e1cb85bc47e142671e7 100644 (file)
@@ -8,8 +8,9 @@ all: swconfig
 %.o: %.c
        $(CC) $(CFLAGS) -fPIC -c -o $@ $^
 
-libsw.so: swlib.o
-       $(CC) $(CFLAGS) -fPIC -shared -o $@ swlib.o
+libsw.a: swlib.o
+       $(AR) rcu $@ swlib.o
+       $(RANLIB) $@
 
-swconfig: libsw.so cli.o uci.o
+swconfig: libsw.a cli.o uci.o
        $(CC) $(LDFLAGS) -o $@ $^ $(LIBS) -L./ -lsw