dropbear: add ssh-askpass support in configuration
[openwrt/openwrt.git] / package / network / services / dropbear / Makefile
index 5021c2aee16620ec4339b23184934952efcebad9..af346f44acd7fadf93dc904b3350083a38c6a64c 100644 (file)
@@ -32,7 +32,7 @@ PKG_CONFIG_DEPENDS:= \
        CONFIG_DROPBEAR_CURVE25519 CONFIG_DROPBEAR_ZLIB \
        CONFIG_DROPBEAR_ED25519 CONFIG_DROPBEAR_CHACHA20POLY1305 \
        CONFIG_DROPBEAR_UTMP CONFIG_DROPBEAR_PUTUTLINE \
-       CONFIG_DROPBEAR_DBCLIENT CONFIG_DROPBEAR_SCP
+       CONFIG_DROPBEAR_DBCLIENT CONFIG_DROPBEAR_SCP CONFIG_DROPBEAR_ASKPASS
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -136,6 +136,7 @@ DB_OPT_CONFIG = \
        DROPBEAR_ECDH|CONFIG_DROPBEAR_ECC|1|0 \
        !!DROPBEAR_ECC_384|CONFIG_DROPBEAR_ECC_FULL|1|0 \
        !!DROPBEAR_ECC_521|CONFIG_DROPBEAR_ECC_FULL|1|0 \
+       DROPBEAR_CLI_ASKPASS_HELPER|CONFIG_DROPBEAR_ASKPASS|1|0 \
 
 
 TARGET_CFLAGS += -DARGTYPE=3 -ffunction-sections -fdata-sections -flto