treewide: add support for "gc-sections" in PKG_BUILD_FLAGS
[openwrt/openwrt.git] / package / network / services / hostapd / Makefile
index 889f1455047400671d13b541fae3f4974368e1c4..1b077530e13d9ec1f24892e2654eab8c6c6ca882 100644 (file)
@@ -32,6 +32,8 @@ PKG_CONFIG_DEPENDS:= \
        CONFIG_DRIVER_11AX_SUPPORT \
        CONFIG_WPA_ENABLE_WEP
 
+PKG_BUILD_FLAGS:=gc-sections
+
 EAPOL_TEST_PROVIDERS:=eapol-test eapol-test-openssl eapol-test-wolfssl
 
 SUPPLICANT_PROVIDERS:=
@@ -585,8 +587,8 @@ TARGET_CPPFLAGS := \
        -D_GNU_SOURCE \
        $(if $(CONFIG_WPA_MSG_MIN_PRIORITY),-DCONFIG_MSG_MIN_PRIORITY=$(CONFIG_WPA_MSG_MIN_PRIORITY))
 
-TARGET_CFLAGS += -ffunction-sections -fdata-sections -flto
-TARGET_LDFLAGS += -Wl,--gc-sections -flto=jobserver -fuse-linker-plugin -lubox -lubus
+TARGET_CFLAGS += -flto
+TARGET_LDFLAGS += -flto=jobserver -fuse-linker-plugin -lubox -lubus
 
 ifdef CONFIG_PACKAGE_kmod-cfg80211
   TARGET_LDFLAGS += -lm -lnl-tiny