hostapd: Remove unneeded patch
[openwrt/openwrt.git] / package / network / services / hostapd / patches / 370-ap_sta_support.patch
index 8a92ead99e784bc6923909b5c719f473aab3d228..f8d420652979fc4975d1f96cb13b6135c5adbadd 100644 (file)
@@ -1,29 +1,6 @@
---- a/wpa_supplicant/wpa_supplicant_i.h
-+++ b/wpa_supplicant/wpa_supplicant_i.h
-@@ -108,6 +108,11 @@ struct wpa_interface {
-       const char *ifname;
-       /**
-+       * hostapd_ctrl - path to hostapd control socket for notification
-+       */
-+      const char *hostapd_ctrl;
-+
-+      /**
-        * bridge_ifname - Optional bridge interface name
-        *
-        * If the driver interface (ifname) is included in a Linux bridge
-@@ -395,6 +400,8 @@ struct wpa_supplicant {
- #endif /* CONFIG_CTRL_IFACE_DBUS_NEW */
-       char bridge_ifname[16];
-+      struct wpa_ctrl *hostapd;
-+
-       char *confname;
-       char *confanother;
 --- a/wpa_supplicant/Makefile
 +++ b/wpa_supplicant/Makefile
-@@ -13,6 +13,10 @@ PKG_CONFIG ?= pkg-config
+@@ -26,6 +26,10 @@ CFLAGS += $(EXTRA_CFLAGS)
  CFLAGS += -I$(abspath ../src)
  CFLAGS += -I$(abspath ../src/utils)
  
  -include .config
  -include $(if $(MULTICALL),../hostapd/.config)
  
-@@ -82,6 +86,8 @@ OBJS_c = wpa_cli.o ../src/common/wpa_ctr
- OBJS_c += ../src/utils/wpa_debug.o
- OBJS_c += ../src/utils/common.o
+@@ -116,6 +120,8 @@ OBJS_c += ../src/utils/common.o
+ OBJS_c += ../src/common/cli.o
+ OBJS += wmm_ac.o
  
 +OBJS += ../src/common/wpa_ctrl.o
 +
  ifndef CONFIG_OS
  ifdef CONFIG_NATIVE_WINDOWS
  CONFIG_OS=win32
+--- a/wpa_supplicant/bss.c
++++ b/wpa_supplicant/bss.c
+@@ -11,6 +11,7 @@
+ #include "utils/common.h"
+ #include "utils/eloop.h"
+ #include "common/ieee802_11_defs.h"
++#include "common/ieee802_11_common.h"
+ #include "drivers/driver.h"
+ #include "eap_peer/eap.h"
+ #include "wpa_supplicant_i.h"
+@@ -294,6 +295,10 @@ void calculate_update_time(const struct
+ static void wpa_bss_copy_res(struct wpa_bss *dst, struct wpa_scan_res *src,
+                            struct os_reltime *fetch_time)
+ {
++      struct ieee80211_ht_capabilities *capab;
++      struct ieee80211_ht_operation *oper;
++      struct ieee802_11_elems elems;
++
+       dst->flags = src->flags;
+       os_memcpy(dst->bssid, src->bssid, ETH_ALEN);
+       dst->freq = src->freq;
+@@ -306,6 +311,15 @@ static void wpa_bss_copy_res(struct wpa_
+       dst->est_throughput = src->est_throughput;
+       dst->snr = src->snr;
++      memset(&elems, 0, sizeof(elems));
++      ieee802_11_parse_elems((u8 *) (src + 1), src->ie_len, &elems, 0);
++      capab = (struct ieee80211_ht_capabilities *) elems.ht_capabilities;
++      oper = (struct ieee80211_ht_operation *) elems.ht_operation;
++      if (capab)
++              dst->ht_capab = le_to_host16(capab->ht_capabilities_info);
++      if (oper)
++              dst->ht_param = oper->ht_param;
++
+       calculate_update_time(fetch_time, src->age, &dst->last_update);
+ }
+--- a/wpa_supplicant/bss.h
++++ b/wpa_supplicant/bss.h
+@@ -82,6 +82,10 @@ struct wpa_bss {
+       u8 ssid[SSID_MAX_LEN];
+       /** Length of SSID */
+       size_t ssid_len;
++      /** HT capabilities */
++      u16 ht_capab;
++      /* Five octets of HT Operation Information */
++      u8 ht_param;
+       /** Frequency of the channel in MHz (e.g., 2412 = channel 1) */
+       int freq;
+       /** Beacon interval in TUs (host byte order) */
+--- a/wpa_supplicant/main.c
++++ b/wpa_supplicant/main.c
+@@ -34,7 +34,7 @@ static void usage(void)
+              "vW] [-P<pid file>] "
+              "[-g<global ctrl>] \\\n"
+              "        [-G<group>] \\\n"
+-             "        -i<ifname> -c<config file> [-C<ctrl>] [-D<driver>] "
++             "        -i<ifname> -c<config file> [-C<ctrl>] [-D<driver>] [-H<hostapd path>] "
+              "[-p<driver_param>] \\\n"
+              "        [-b<br_ifname>] [-e<entropy file>]"
+ #ifdef CONFIG_DEBUG_FILE
+@@ -74,6 +74,7 @@ static void usage(void)
+              "  -g = global ctrl_interface\n"
+              "  -G = global ctrl_interface group\n"
+              "  -h = show this help text\n"
++             "  -H = connect to a hostapd instance to manage state changes\n"
+              "  -i = interface name\n"
+              "  -I = additional configuration file\n"
+              "  -K = include keys (passwords, etc.) in debug output\n"
+@@ -201,7 +202,7 @@ int main(int argc, char *argv[])
+       for (;;) {
+               c = getopt(argc, argv,
+-                         "b:Bc:C:D:de:f:g:G:hi:I:KLMm:No:O:p:P:qsTtuvW");
++                         "b:Bc:C:D:de:f:g:G:hH:i:I:KLMm:No:O:p:P:qsTtuvW");
+               if (c < 0)
+                       break;
+               switch (c) {
+@@ -248,6 +249,9 @@ int main(int argc, char *argv[])
+                       usage();
+                       exitcode = 0;
+                       goto out;
++              case 'H':
++                      iface->hostapd_ctrl = optarg;
++                      break;
+               case 'i':
+                       iface->ifname = optarg;
+                       break;
 --- a/wpa_supplicant/wpa_supplicant.c
 +++ b/wpa_supplicant/wpa_supplicant.c
-@@ -105,6 +105,55 @@ const char *wpa_supplicant_full_license5
- "\n";
- #endif /* CONFIG_NO_STDOUT_DEBUG */
+@@ -127,6 +127,55 @@ static void wpas_update_fils_connect_par
+ #endif /* CONFIG_FILS && IEEE8021X_EAPOL */
  
 +static int hostapd_stop(struct wpa_supplicant *wpa_s)
 +{
-+      const char *cmd = "DOWN";
++      const char *cmd = "STOP_AP";
 +      char buf[256];
-+      int len = sizeof(buf);
++      size_t len = sizeof(buf);
 +
 +      if (wpa_ctrl_request(wpa_s->hostapd, cmd, os_strlen(cmd), buf, &len, NULL) < 0) {
 +              wpa_printf(MSG_ERROR, "\nFailed to stop hostapd AP interfaces\n");
 +{
 +      char *cmd = NULL;
 +      char buf[256];
-+      int len = sizeof(buf);
++      size_t len = sizeof(buf);
 +      enum hostapd_hw_mode hw_mode;
 +      u8 channel;
 +      int sec_chan = 0;
 +      int ret;
 +
 +      if (!bss)
-+              return;
++              return -1;
 +
 +      if (bss->ht_param & HT_INFO_HT_PARAM_STA_CHNL_WIDTH) {
 +              int sec = bss->ht_param & HT_INFO_HT_PARAM_SECONDARY_CHNL_OFF_MASK;
 +      }
 +
 +      hw_mode = ieee80211_freq_to_chan(bss->freq, &channel);
-+      if (asprintf(&cmd, "UPDATE channel=%d sec_chan=%d hw_mode=%d ieee80211n=%d",
-+                   channel, sec_chan, hw_mode, !!bss->ht_capab) < 0)
++      if (asprintf(&cmd, "UPDATE channel=%d sec_chan=%d hw_mode=%d",
++                   channel, sec_chan, hw_mode) < 0)
 +              return -1;
 +
 +      ret = wpa_ctrl_request(wpa_s->hostapd, cmd, os_strlen(cmd), buf, &len, NULL);
  /* Configure default/group WEP keys for static WEP */
  int wpa_set_wep_keys(struct wpa_supplicant *wpa_s, struct wpa_ssid *ssid)
  {
-@@ -711,8 +760,12 @@ void wpa_supplicant_set_state(struct wpa
- #endif /* CONFIG_P2P */
+@@ -940,12 +989,16 @@ void wpa_supplicant_set_state(struct wpa
  
                sme_sched_obss_scan(wpa_s, 1);
 +              if (wpa_s->hostapd)
 +                      hostapd_reload(wpa_s, wpa_s->current_bss);
+ #if defined(CONFIG_FILS) && defined(IEEE8021X_EAPOL)
+               if (!fils_hlp_sent && ssid && ssid->eap.erp)
+                       wpas_update_fils_connect_params(wpa_s);
+ #endif /* CONFIG_FILS && IEEE8021X_EAPOL */
        } else if (state == WPA_DISCONNECTED || state == WPA_ASSOCIATING ||
                   state == WPA_ASSOCIATED) {
 +              if (wpa_s->hostapd)
                wpa_s->new_connection = 1;
                wpa_drv_set_operstate(wpa_s, 0);
  #ifndef IEEE8021X_EAPOL
-@@ -3595,6 +3648,20 @@ static int wpa_supplicant_init_iface(str
+@@ -2038,6 +2091,8 @@ void wpa_supplicant_associate(struct wpa
+                       wpa_ssid_txt(ssid->ssid, ssid->ssid_len),
+                       ssid->id);
+               wpas_notify_mesh_group_started(wpa_s, ssid);
++              if (wpa_s->hostapd)
++                      hostapd_reload(wpa_s, wpa_s->current_bss);
+ #else /* CONFIG_MESH */
+               wpa_msg(wpa_s, MSG_ERROR,
+                       "mesh mode support not included in the build");
+@@ -5716,6 +5771,16 @@ static int wpa_supplicant_init_iface(str
                           sizeof(wpa_s->bridge_ifname));
        }
  
 +      if (iface->hostapd_ctrl) {
-+              char *cmd = "DOWN";
-+              char buf[256];
-+              int len = sizeof(buf);
-+
 +              wpa_s->hostapd = wpa_ctrl_open(iface->hostapd_ctrl);
 +              if (!wpa_s->hostapd) {
 +                      wpa_printf(MSG_ERROR, "\nFailed to connect to hostapd\n");
        /* RSNA Supplicant Key Management - INITIALIZE */
        eapol_sm_notify_portEnabled(wpa_s->eapol, FALSE);
        eapol_sm_notify_portValid(wpa_s->eapol, FALSE);
-@@ -3798,6 +3865,11 @@ static void wpa_supplicant_deinit_iface(
+@@ -6043,6 +6108,11 @@ static void wpa_supplicant_deinit_iface(
        if (terminate)
                wpa_msg(wpa_s, MSG_INFO, WPA_EVENT_TERMINATING);
  
        if (wpa_s->ctrl_iface) {
                wpa_supplicant_ctrl_iface_deinit(wpa_s->ctrl_iface);
                wpa_s->ctrl_iface = NULL;
---- a/wpa_supplicant/bss.c
-+++ b/wpa_supplicant/bss.c
-@@ -11,6 +11,7 @@
- #include "utils/common.h"
- #include "utils/eloop.h"
- #include "common/ieee802_11_defs.h"
-+#include "common/ieee802_11_common.h"
- #include "drivers/driver.h"
- #include "wpa_supplicant_i.h"
- #include "config.h"
-@@ -247,6 +248,10 @@ static void calculate_update_time(const 
- static void wpa_bss_copy_res(struct wpa_bss *dst, struct wpa_scan_res *src,
-                            struct os_reltime *fetch_time)
- {
-+      struct ieee80211_ht_capabilities *capab;
-+      struct ieee80211_ht_operation *oper;
-+      struct ieee802_11_elems elems;
+--- a/wpa_supplicant/wpa_supplicant_i.h
++++ b/wpa_supplicant/wpa_supplicant_i.h
+@@ -101,6 +101,11 @@ struct wpa_interface {
+       const char *ifname;
+       /**
++       * hostapd_ctrl - path to hostapd control socket for notification
++       */
++      const char *hostapd_ctrl;
 +
-       dst->flags = src->flags;
-       os_memcpy(dst->bssid, src->bssid, ETH_ALEN);
-       dst->freq = src->freq;
-@@ -257,6 +262,15 @@ static void wpa_bss_copy_res(struct wpa_
-       dst->level = src->level;
-       dst->tsf = src->tsf;
++      /**
+        * bridge_ifname - Optional bridge interface name
+        *
+        * If the driver interface (ifname) is included in a Linux bridge
+@@ -516,6 +521,8 @@ struct wpa_supplicant {
+ #endif /* CONFIG_CTRL_IFACE_BINDER */
+       char bridge_ifname[16];
  
-+      memset(&elems, 0, sizeof(elems));
-+      ieee802_11_parse_elems((u8 *) (src + 1), src->ie_len, &elems, 0);
-+      capab = (struct ieee80211_ht_capabilities *) elems.ht_capabilities;
-+      oper = (struct ieee80211_ht_operation *) elems.ht_operation;
-+      if (capab)
-+              dst->ht_capab = le_to_host16(capab->ht_capabilities_info);
-+      if (oper)
-+              dst->ht_param = oper->ht_param;
++      struct wpa_ctrl *hostapd;
 +
-       calculate_update_time(fetch_time, src->age, &dst->last_update);
- }
+       char *confname;
+       char *confanother;
  
---- a/wpa_supplicant/main.c
-+++ b/wpa_supplicant/main.c
-@@ -33,7 +33,7 @@ static void usage(void)
-              "vW] [-P<pid file>] "
-              "[-g<global ctrl>] \\\n"
-              "        [-G<group>] \\\n"
--             "        -i<ifname> -c<config file> [-C<ctrl>] [-D<driver>] "
-+             "        -i<ifname> -c<config file> [-C<ctrl>] [-D<driver>] [-H<hostapd path>] "
-              "[-p<driver_param>] \\\n"
-              "        [-b<br_ifname>] [-e<entropy file>]"
- #ifdef CONFIG_DEBUG_FILE
-@@ -84,6 +84,7 @@ static void usage(void)
- #endif /* CONFIG_DEBUG_LINUX_TRACING */
-       printf("  -t = include timestamp in debug messages\n"
-              "  -h = show this help text\n"
-+                 "  -H = connect to a hostapd instance to manage state changes\n"
-              "  -L = show license (BSD)\n"
-              "  -o = override driver parameter for new interfaces\n"
-              "  -O = override ctrl_interface parameter for new interfaces\n"
-@@ -175,7 +176,7 @@ int main(int argc, char *argv[])
+--- a/hostapd/ctrl_iface.c
++++ b/hostapd/ctrl_iface.c
+@@ -2408,6 +2408,11 @@ static int hostapd_ctrl_iface_chan_switc
+       if (ret)
+               return ret;
  
-       for (;;) {
-               c = getopt(argc, argv,
--                         "b:Bc:C:D:de:f:g:G:hi:I:KLm:No:O:p:P:qsTtuvW");
-+                         "b:Bc:C:D:de:f:g:G:hH:i:I:KLm:No:O:p:P:qsTtuvW");
-               if (c < 0)
-                       break;
-               switch (c) {
-@@ -222,6 +223,9 @@ int main(int argc, char *argv[])
-                       usage();
-                       exitcode = 0;
-                       goto out;
-+              case 'H':
-+                      iface->hostapd_ctrl = optarg;
-+                      break;
-               case 'i':
-                       iface->ifname = optarg;
-                       break;
---- a/wpa_supplicant/bss.h
-+++ b/wpa_supplicant/bss.h
-@@ -70,6 +70,10 @@ struct wpa_bss {
-       u8 ssid[32];
-       /** Length of SSID */
-       size_t ssid_len;
-+      /** HT caapbilities */
-+      u16 ht_capab;
-+      /* Five octets of HT Operation Information */
-+      u8 ht_param;
-       /** Frequency of the channel in MHz (e.g., 2412 = channel 1) */
-       int freq;
-       /** Beacon interval in TUs (host byte order) */
++      if (os_strstr(pos, " auto-ht")) {
++              settings.freq_params.ht_enabled = iface->conf->ieee80211n;
++              settings.freq_params.vht_enabled = iface->conf->ieee80211ac;
++      }
++
+       for (i = 0; i < iface->num_bss; i++) {
+               /* Save CHAN_SWITCH VHT config */
+--- a/src/ap/beacon.c
++++ b/src/ap/beacon.c
+@@ -1403,11 +1403,6 @@ int ieee802_11_set_beacon(struct hostapd
+       struct wpabuf *beacon, *proberesp, *assocresp;
+       int res, ret = -1;
+-      if (hapd->csa_in_progress) {
+-              wpa_printf(MSG_ERROR, "Cannot set beacons during CSA period");
+-              return -1;
+-      }
+-
+       hapd->beacon_set_done = 1;
+       if (ieee802_11_build_ap_params(hapd, &params) < 0)