igmpproxy: update init.d script to procd and add a hotplug script
[openwrt/openwrt.git] / package / network / services / igmpproxy / Makefile
index 47b995bb5188c0438c1a279f0e6f640c3d727809..027fcb99d214bac94c36b934d80d02d7f45ca00d 100644 (file)
@@ -51,6 +51,8 @@ define Package/igmpproxy/install
        $(INSTALL_CONF) ./files/igmpproxy.config $(1)/etc/config/igmpproxy
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/igmpproxy.init $(1)/etc/init.d/igmpproxy
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
+       $(INSTALL_BIN) ./files/igmpproxy.hotplug $(1)/etc/hotplug.d/iface/igmpproxy
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/igmpproxy $(1)/usr/sbin/
 endef