omcproxy: add new igmpv3 & mldv2 multicast proxy
[openwrt/openwrt.git] / package / network / services / omcproxy / Makefile
diff --git a/package/network/services/omcproxy/Makefile b/package/network/services/omcproxy/Makefile
new file mode 100644 (file)
index 0000000..2583d17
--- /dev/null
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=omcproxy
+PKG_VERSION:=2015-08-24
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_URL:=https://github.com/sbyx/omcproxy.git
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_VERSION:=8df8017b8bc6d31e975d72361d8f9512e743d0c7
+PKG_MAINTAINER:=Steven Barth <cyrus@openwrt.org>
+PKG_LICENSE:=APACHE-2.0
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+define Package/omcproxy
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+libubox +libubus
+  TITLE:=IGMPv3 and MLDv2 Multicast Proxy
+endef
+
+CMAKE_OPTIONS += -DWITH_LIBUBOX=1 -DWITH_UBUS=1
+
+define Package/omcproxy/install
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_CONF) ./files/omcproxy.config $(1)/etc/config/omcproxy
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/omcproxy.init $(1)/etc/init.d/omcproxy
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/omcproxy $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,omcproxy))