ppp: Update to version 2.4.9
[openwrt/openwrt.git] / package / network / services / ppp / patches / 200-makefile.patch
index 9db908de8d5505bf48c056c61acefe35efe6c9aa..d0b9a9a99bdb72b0f647aad6f5d4f599c2e4b628 100644 (file)
@@ -3,11 +3,11 @@ pppd: tune Linux config defaults for OpenWrt
 This patch adjusts a number defaults to properly match the OpenWrt environment.
 It is not intended for upstream.
 
-Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
+Signed-off-by: Jo-Philipp Wich <jo@mein.io>
 
 --- a/pppd/Makefile.linux
 +++ b/pppd/Makefile.linux
-@@ -48,7 +48,7 @@ MPPE=y
+@@ -49,7 +49,7 @@ MPPE=y
  # Uncomment the next line to include support for PPP packet filtering.
  # This requires that the libpcap library and headers be installed
  # and that the kernel driver support PPP packet filtering.
@@ -16,40 +16,41 @@ Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
  
  # Uncomment the next line to enable multilink PPP (enabled by default)
  # Linux distributions: Please leave multilink ENABLED in your builds
-@@ -58,11 +58,11 @@ HAVE_MULTILINK=y
+@@ -59,7 +59,7 @@ HAVE_MULTILINK=y
  # Uncomment the next line to enable the TDB database (enabled by default.)
  # If you enable multilink, then TDB is automatically enabled also.
  # Linux distributions: Please leave TDB ENABLED in your builds.
 -USE_TDB=y
 +#USE_TDB=y
  
--HAS_SHADOW=y
-+#HAS_SHADOW=y
- #USE_PAM=y
--#HAVE_INET6=y
-+HAVE_INET6=y
+ # Uncomment the next line to enable Type=notify services in systemd
+ # If enabled, and the user sets the up_sdnotify option, then
+@@ -85,13 +85,13 @@ USE_LIBUTIL=y
+ endif
+ # Enable EAP-TLS authentication (requires MPPE support, libssl and libcrypto)
+-USE_EAPTLS=y
++#USE_EAPTLS=y
  
- # Enable plugins
- PLUGIN=y
-@@ -77,7 +77,7 @@ MAXOCTETS=y
+ MAXOCTETS=y
  
  INCLUDE_DIRS= -I../include
  
--COMPILE_FLAGS= -DHAVE_PATHS_H -DIPX_CHANGE -DHAVE_MMAP
-+COMPILE_FLAGS= -DHAVE_PATHS_H -DHAVE_MMAP
+-COMPILE_FLAGS= -DHAVE_PATHS_H -DIPX_CHANGE -DHAVE_MMAP -pipe
++COMPILE_FLAGS= -DHAVE_PATHS_H -DHAVE_MMAP -pipe
  
  CFLAGS= $(COPTS) $(COMPILE_FLAGS) $(INCLUDE_DIRS) '-DDESTDIR="@DESTDIR@"'
  
-@@ -117,10 +117,10 @@ CFLAGS   += -DHAS_SHADOW
+@@ -143,10 +143,10 @@ CFLAGS   += -DHAS_SHADOW
  #LIBS     += -lshadow $(LIBS)
  endif
  
--ifneq ($(wildcard /usr/include/crypt.h),)
-+#ifneq ($(wildcard /usr/include/crypt.h),)
+-ifeq ($(shell echo '\#include <crypt.h>' | $(CC) -E - >/dev/null 2>&1 && echo yes),yes)
++#ifeq ($(shell echo '\#include <crypt.h>' | $(CC) -E - >/dev/null 2>&1 && echo yes),yes)
  CFLAGS  += -DHAVE_CRYPT_H=1
  LIBS  += -lcrypt
 -endif
 +#endif
  
- ifdef NEEDDES
- ifndef USE_CRYPT
+ ifdef USE_LIBUTIL
+ CFLAGS        += -DHAVE_LOGWTMP=1