iproute2: update to 5.16.0
[openwrt/openwrt.git] / package / network / utils / iproute2 / patches / 170-ip_tiny.patch
index cd687e760104462be127ef9d3787751e0c5e1114..399dd4fc87f0f4e2ab30755d5bc5dc1fc6863aae 100644 (file)
@@ -1,6 +1,6 @@
 --- a/ip/Makefile
 +++ b/ip/Makefile
-@@ -17,6 +17,13 @@ RTMONOBJ=rtmon.o
+@@ -18,6 +18,13 @@ RTMONOBJ=rtmon.o
  
  include ../config.mk
  
@@ -12,9 +12,9 @@
 +STATIC_SYM_SOURCES:=$(filter-out $(STATIC_SYM_FILTER),$(wildcard *.c))
 +
  ALLOBJ=$(IPOBJ) $(RTMONOBJ)
- SCRIPTS=ifcfg rtpr routel routef
+ SCRIPTS=routel
  TARGETS=ip rtmon
-@@ -46,7 +53,7 @@ else
+@@ -47,7 +54,7 @@ else
  
  ip: static-syms.o
  static-syms.o: static-syms.h
@@ -30,8 +30,8 @@
                "Usage: ip [ OPTIONS ] OBJECT { COMMAND | help }\n"
                "       ip [ -force ] -batch filename\n"
 +#ifndef IPROUTE2_TINY
-               "where  OBJECT := { address | addrlabel | fou | help | ila | ioam | l2tp | link |\n"
-               "                   macsec | maddress | monitor | mptcp | mroute | mrule |\n"
+               "where  OBJECT := { address | addrlabel | amt | fou | help | ila | ioam | l2tp |\n"
+               "                   link | macsec | maddress | monitor | mptcp | mroute | mrule |\n"
                "                   neighbor | neighbour | netconf | netns | nexthop | ntable |\n"
                "                   ntbl | route | rule | sr | tap | tcpmetrics |\n"
                "                   token | tunnel | tuntap | vrf | xfrm }\n"