lantiq: move dsl related base-files into own package
[openwrt/openwrt.git] / package / network / utils / ltq-dsl-base / Makefile
diff --git a/package/network/utils/ltq-dsl-base/Makefile b/package/network/utils/ltq-dsl-base/Makefile
new file mode 100644 (file)
index 0000000..6b931f7
--- /dev/null
@@ -0,0 +1,32 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ltq-dsl-base
+PKG_RELEASE:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/ltq-dsl-base
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=DSL related files for Intel/Lantiq DSL Chipsets
+  URL:=http://openwrt.org/
+  DEPENDS:=@TARGET_lantiq +jshn
+endef
+
+define Package/ltq-dsl-base/description
+  This package contains DSL related files for Intel/Lantiq DSL Chipsets.
+endef
+
+define Build/Compile
+endef
+
+define Package/ltq-dsl-base/install
+       $(CP) ./files/* $(1)/
+endef
+
+$(eval $(call BuildPackage,ltq-dsl-base))