ubus: compile with LTO enabled
[openwrt/openwrt.git] / package / system / ubus / Makefile
index 7dc3c92deadbaf0e15d8e0135585b6e8cbc0e8c5..523c3629fc6709d3418068303311a7ef2fd289db 100644 (file)
@@ -47,7 +47,8 @@ define Package/libubus-lua
   TITLE:=Lua binding for the OpenWrt RPC client
 endef
 
-TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
+TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include -flto
+TARGET_LDFLAGS += -flto
 
 CMAKE_OPTIONS = \
        -DLUAPATH=/usr/lib/lua