replace lots of manual install commands with INSTALL_* variables
[openwrt/openwrt.git] / package / wlcompat / Makefile
index 4a372946581cd7241f4874ef839cc3bbfae89ed1..44acaee1f1174ca1f7dedae4791d385497d38faf 100644 (file)
@@ -62,14 +62,14 @@ define Build/Compile
 endef
 
 define Package/kmod-wlcompat/install
-       install -d -m0755 $(1)/lib/modules/$(LINUX_VERSION)
+       $(INSTALL_DIR) $(1)/lib/modules/$(LINUX_VERSION)
        $(CP) $(PKG_BUILD_DIR)/wlcompat.o $(1)/lib/modules/$(LINUX_VERSION)/
-       install -d -m0755 $(1)/etc/modules.d
+       $(INSTALL_DIR) $(1)/etc/modules.d
        echo "wlcompat" > $(1)/etc/modules.d/30-wlcompat
 endef
 
 define Package/kmod-wlcompat-debug/install
-       install -d -m0755 $(1)/lib/modules/$(LINUX_VERSION)
+       $(INSTALL_DIR) $(1)/lib/modules/$(LINUX_VERSION)
        $(CP) $(PKG_BUILD_DIR)/wlcompat-debug.o $(1)/lib/modules/$(LINUX_VERSION)/
 endef