use $(FPIC) in a few places where it matters
[openwrt/openwrt.git] / package / zlib / Makefile
index 9cf92197b7b8c5099e009ebfd3f3267ebf8b80da..9c8058bfa5e93fab2b4780e9e5277fc83e69a47e 100644 (file)
@@ -29,7 +29,7 @@ define Build/Configure
        (cd $(PKG_BUILD_DIR); \
                $(TARGET_CONFIGURE_OPTS) \
                LDSHARED="$(TARGET_CC) -shared -Wl,-soname,libz.so.1" \
-               CFLAGS="$(TARGET_CFLAGS) -fPIC $(CFLAGS_LARGEFILE)" \
+               CFLAGS="$(TARGET_CFLAGS) $(FPIC) $(CFLAGS_LARGEFILE)" \
                UNAME_S="Linux" \
                ./configure \
                        --prefix=/usr \