imagebuilder: allow to specific ROOTFS_PARTSIZE
[openwrt/openwrt.git] / target / imagebuilder / files / Makefile
index 275932577b4c7024e4bb2e496f4c36cbdca0628d..5aeedb74dadab41f6b3249a3ce2f1229372ef4d9 100644 (file)
@@ -51,6 +51,7 @@ image:
        make image EXTRA_IMAGE_NAME="<string>" # Add this to the output image filename (sanitized)
        make image DISABLED_SERVICES="<svc1> [<svc2> [<svc3> ..]]" # Which services in /etc/init.d/ should be disabled
        make image ADD_LOCAL_KEY=1 # store locally generated signing key in built images
        make image EXTRA_IMAGE_NAME="<string>" # Add this to the output image filename (sanitized)
        make image DISABLED_SERVICES="<svc1> [<svc2> [<svc3> ..]]" # Which services in /etc/init.d/ should be disabled
        make image ADD_LOCAL_KEY=1 # store locally generated signing key in built images
+       make image ROOTFS_PARTSIZE="<size>" # override the default rootfs partition size in MegaBytes
 
 manifest:
        List "all" packages which get installed into the image.
 
 manifest:
        List "all" packages which get installed into the image.
@@ -261,7 +262,8 @@ image:
                $(if $(FILES),USER_FILES="$(FILES)") \
                $(if $(PACKAGES),USER_PACKAGES="$(PACKAGES)") \
                $(if $(BIN_DIR),BIN_DIR="$(BIN_DIR)") \
                $(if $(FILES),USER_FILES="$(FILES)") \
                $(if $(PACKAGES),USER_PACKAGES="$(PACKAGES)") \
                $(if $(BIN_DIR),BIN_DIR="$(BIN_DIR)") \
-               $(if $(DISABLED_SERVICES),DISABLED_SERVICES="$(DISABLED_SERVICES)"))
+               $(if $(DISABLED_SERVICES),DISABLED_SERVICES="$(DISABLED_SERVICES)") \
+               $(if $(ROOTFS_PARTSIZE),CONFIG_TARGET_ROOTFS_PARTSIZE="$(ROOTFS_PARTSIZE)"))
 
 manifest: FORCE
        $(MAKE) -s _check_profile
 
 manifest: FORCE
        $(MAKE) -s _check_profile