add ar7 sErCoMm image fix (patch by Bernardo Innocenti)
[openwrt/openwrt.git] / target / linux / ar7-2.4 / image / Makefile
index bcdef970cfb8ba05ce1ec9e6c6ddd20482f2720f..e10d1aa5c19aaf7705258a7d284689446ebd2eea 100644 (file)
@@ -80,7 +80,7 @@ define Image/Build/CyberTAN
 endef
 
 define Image/Build/sErCoMm
-       cat sercomm/adam2.bin "$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin" > "$(BIN_DIR)/openwrt-$(2)-$(KERNEL)-$(3).img"
+       cat sercomm/adam2.bin "$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin" > "$(KDIR)/dgfw.tmp"
        dd if=sercomm/$(2) of="$(KDIR)/dgfw.tmp" bs=$$$$((0x3e0000 - 80)) seek=1 conv=notrunc
        $(STAGING_DIR)/bin/dgfirmware -f -w "$(BIN_DIR)/openwrt-$(2)-$(KERNEL)-$(3).img" "$(KDIR)/dgfw.tmp"
        rm -f "$(KDIR)/dgfw.tmp"