ar71xx: add support for hornet-ub-x2
[openwrt/openwrt.git] / target / linux / ar71xx / generic / profiles / alfa.mk
index 06baf240c21b44455ab82f0dcc8cf83771e1c981..97c843ace1bf1400041e36a44cfe44e325b32163 100644 (file)
@@ -1,12 +1,12 @@
 #
-# Copyright (C) 2011 OpenWrt.org
+# Copyright (C) 2011-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
 define Profile/ALFAAP96
-       NAME:=ALFA Network AP96  board
+       NAME:=ALFA Network AP96 board
        PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-rtc-pcf2123
 endef
 
@@ -18,17 +18,31 @@ $(eval $(call Profile,ALFAAP96))
 
 
 define Profile/HORNETUB
-       NAME:=ALFA Network Hornet-UB board
+       NAME:=ALFA Network Hornet-UB board (8MB flash, 32MB ram)
        PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
 endef
 
 define Profile/HORNETUB/Description
-       Package set optimized for the ALFA Network Hornet-UB board.
+       Package set optimized for the ALFA Network Hornet-UB board with 8MB
+       flash and 32MB ram.
 endef
 
 $(eval $(call Profile,HORNETUB))
 
 
+define Profile/HORNETUBx2
+       NAME:=ALFA Network Hornet-UB-x2 board (16MB flash, 64MB ram)
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/HORNETUBx2/Description
+       Package set optimized for the ALFA Network Hornet-UB board with 16MB
+       flash and 64MB ram.
+endef
+
+$(eval $(call Profile,HORNETUBx2))
+
+
 define Profile/ALFANX
        NAME:=ALFA Network N2/N5 board
        PACKAGES:=
@@ -39,4 +53,3 @@ define Profile/ALFANX/Description
 endef
 
 $(eval $(call Profile,ALFANX))
-