ar71xx: merge profiles into image building code
[openwrt/openwrt.git] / target / linux / ar71xx / generic / profiles / devolo-dlan.mk
diff --git a/target/linux/ar71xx/generic/profiles/devolo-dlan.mk b/target/linux/ar71xx/generic/profiles/devolo-dlan.mk
deleted file mode 100644 (file)
index 44a6869..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
-#
-# Copyright (C) 2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/dLAN_Hotspot
-       NAME:=devolo dLAN Hotspot
-       PACKAGES:=open-plc-utils open-plc-utils-chkpib open-plc-utils-getpib open-plc-utils-modpib \
-               open-plc-utils-setpib open-plc-utils-hpavkey open-plc-utils-plchost \
-               open-plc-utils-plctool open-plc-utils-pibdump open-plc-utils-plcstat \
-               ebtables hostapd-utils wifitoggle wpad
-endef
-
-define Profile/dLAN_Hotspot/Description
-       Package set optimized for the devolo dLAN Hotspot.
-endef
-$(eval $(call Profile,dLAN_Hotspot))
-
-define Profile/dLAN_pro_500_wp
-       NAME:=devolo dLAN pro 500 Wireless+
-       PACKAGES:=open-plc-utils open-plc-utils-chkpib open-plc-utils-getpib open-plc-utils-modpib \
-               open-plc-utils-setpib open-plc-utils-hpavkey open-plc-utils-amphost \
-               open-plc-utils-plctool open-plc-utils-pibdump open-plc-utils-plcstat \
-               ebtables hostapd-utils wifitoggle wpad
-endef
-
-define Profile/dLAN_pro_500_wp/Description
-       Package set optimized for the devolo dLAN pro 500 Wireless+.
-endef
-$(eval $(call Profile,dLAN_pro_500_wp))
-
-define Profile/dLAN_pro_1200_ac
-       NAME:=devolo dLAN pro 1200+ WiFi ac
-       PACKAGES:=open-plc-utils open-plc-utils-chkpib open-plc-utils-getpib open-plc-utils-modpib \
-               open-plc-utils-setpib open-plc-utils-hpavkey open-plc-utils-plchost \
-               open-plc-utils-plctool open-plc-utils-pibdump open-plc-utils-plcstat \
-               ebtables hostapd-utils wifitoggle wpad ip-full kmod-ath10k kmod-leds-gpio \
-               kmod-ledtrig-gpio
-endef
-
-define Profile/dLAN_pro_1200_ac/Description
-       Package set optimized for the devolo dLAN pro 1200+ WiFi ac.
-endef
-$(eval $(call Profile,dLAN_pro_1200_ac))