ar71xx: clean up profiles, put in kmod-ath9k and wpad-mini by default (fixes #9954)
[openwrt/openwrt.git] / target / linux / ar71xx / generic / profiles / tp-link.mk
index 776cc0ba2a05e48d82eb55130060318e05cd3ab0..bc0bcd20e1827e0e2fed67c199e2fadb0d4042a0 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/TLMR3220V1
        NAME:=TP-LINK TL-MR3220 v1
-       PACKAGES:=kmod-ath9k wpad-mini kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
 endef
 
 define Profile/TLMR3220V1/Description
@@ -18,7 +18,7 @@ $(eval $(call Profile,TLMR3220V1))
 
 define Profile/TLMR3420V1
        NAME:=TP-LINK TL-MR3420 v1
-       PACKAGES:=kmod-ath9k wpad-mini kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
 endef
 
 define Profile/TLMR3420V1/Description
@@ -29,7 +29,7 @@ $(eval $(call Profile,TLMR3420V1))
 
 define Profile/TLWA901NDV1
        NAME:=TP-LINK TL-WA901ND v1
-       PACKAGES:=kmod-ath9k wpad-mini
+       PACKAGES:=
 endef
 
 define Profile/TLWA901NDV1/Description
@@ -40,7 +40,7 @@ $(eval $(call Profile,TLWA901NDV1))
 
 define Profile/TLWA901NDV2
        NAME:=TP-LINK TL-WA901ND v2
-       PACKAGES:=kmod-ath9k wpad-mini
+       PACKAGES:=
 endef
 
 define Profile/TLWA901NDV2/Description
@@ -51,7 +51,7 @@ $(eval $(call Profile,TLWA901NDV2))
 
 define Profile/TLWR741NDV1
        NAME:=TP-LINK TL-WR741ND v1
-       PACKAGES:=kmod-ath9k wpad-mini
+       PACKAGES:=
 endef
 
 define Profile/TLWR741NDV1/Description
@@ -62,7 +62,7 @@ $(eval $(call Profile,TLWR741NDV1))
 
 define Profile/TLWR740NV1
        NAME:=TP-LINK TL-WR740N v1
-       PACKAGES:=kmod-ath9k wpad-mini
+       PACKAGES:=
 endef
 
 define Profile/TLWR740NV1/Description
@@ -73,7 +73,7 @@ $(eval $(call Profile,TLWR740NV1))
 
 define Profile/TLWR841NV15
        NAME:=TP-LINK TL-WR841N v1.5
-       PACKAGES:=kmod-ath9k wpad-mini
+       PACKAGES:=
 endef
 
 define Profile/TLWR841NV15/Description
@@ -84,7 +84,7 @@ $(eval $(call Profile,TLWR841NV15))
 
 define Profile/TLWR841NDV3
        NAME:=TP-LINK TL-WR841ND v3
-       PACKAGES:=kmod-ath9k wpad-mini
+       PACKAGES:=
 endef
 
 define Profile/TLWR841NDV3/Description
@@ -95,7 +95,7 @@ $(eval $(call Profile,TLWR841NDV3))
 
 define Profile/TLWR841NDV5
        NAME:=TP-LINK TL-WR841ND v5
-       PACKAGES:=kmod-ath9k wpad-mini
+       PACKAGES:=
 endef
 
 define Profile/TLWR841NDV5/Description
@@ -106,7 +106,7 @@ $(eval $(call Profile,TLWR841NDV5))
 
 define Profile/TLWR841NDV7
        NAME:=TP-LINK TL-WR841ND v7
-       PACKAGES:=kmod-ath9k wpad-mini
+       PACKAGES:=
 endef
 
 define Profile/TLWR841NDV7/Description
@@ -117,7 +117,7 @@ $(eval $(call Profile,TLWR841NDV7))
 
 define Profile/TLWR941NDV2
        NAME:=TP-LINK TL-WR941ND v2
-       PACKAGES:=kmod-ath9k wpad-mini
+       PACKAGES:=
 endef
 
 define Profile/TLWR941NDV2/Description
@@ -128,7 +128,7 @@ $(eval $(call Profile,TLWR941NDV2))
 
 define Profile/TLWR941NDV3
        NAME:=TP-LINK TL-WR941ND v3
-       PACKAGES:=kmod-ath9k wpad-mini
+       PACKAGES:=
 endef
 
 define Profile/TLWR941NDV3/Description
@@ -139,7 +139,7 @@ $(eval $(call Profile,TLWR941NDV3))
 
 define Profile/TLWR941NDV4
        NAME:=TP-LINK TL-WR941ND v4
-       PACKAGES:=kmod-ath9k wpad-mini
+       PACKAGES:=
 endef
 
 define Profile/TLWR941NDV4/Description
@@ -150,7 +150,7 @@ $(eval $(call Profile,TLWR941NDV4))
 
 define Profile/TLWR1043NDV1
        NAME:=TP-LINK TL-WR1043ND v1
-       PACKAGES:=kmod-ath9k wpad-mini kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
 endef
 
 define Profile/TLWR1043NDV1/Description