ar71xx: add a new subtarget for nand based devices - saves around 44k on the lzma...
[openwrt/openwrt.git] / target / linux / ar71xx / generic / profiles / trendnet.mk
diff --git a/target/linux/ar71xx/generic/profiles/trendnet.mk b/target/linux/ar71xx/generic/profiles/trendnet.mk
new file mode 100644 (file)
index 0000000..20a08f3
--- /dev/null
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/TEW632BRP
+       NAME:=TRENDNet TEW-632BRP
+       PACKAGES:=kmod-ath9k wpad-mini
+endef
+
+define Profile/TEW632BRP/Description
+       Package set optimized for the TRENDNet TEW-632BRP.
+endef
+
+$(eval $(call Profile,TEW632BRP))
+
+define Profile/TEW652BRP
+       NAME:=TRENDNet TEW-652BRP
+       PACKAGES:=kmod-ath9k
+endef
+
+define Profile/TEW652BRP/Description
+       Package set optimized for the TRENDNet TEW-652BRP.
+endef
+
+$(eval $(call Profile,TEW652BRP))