add SPI controller driver for the PB44 board
[openwrt/openwrt.git] / target / linux / ar71xx / patches-2.6.28 / 203-pb44_spi_controller.patch
diff --git a/target/linux/ar71xx/patches-2.6.28/203-pb44_spi_controller.patch b/target/linux/ar71xx/patches-2.6.28/203-pb44_spi_controller.patch
new file mode 100644 (file)
index 0000000..e48710c
--- /dev/null
@@ -0,0 +1,27 @@
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -68,6 +68,14 @@ config SPI_AR71XX
+       help
+         This is the SPI contoller driver for Atheros AR71xx.
++config SPI_PB44
++      tristate "Atheros PB44 board specific SPI controller"
++      depends on SPI_MASTER && AR71XX_MACH_PB44
++      select SPI_BITBANG
++      help
++        This is a specific SPI controller driver for the Atheros PB44
++        reference board.
++
+ config SPI_ATMEL
+       tristate "Atmel SPI Controller"
+       depends on (ARCH_AT91 || AVR32)
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -22,6 +22,7 @@ obj-$(CONFIG_SPI_GPIO)                       += spi_gpio.o
+ obj-$(CONFIG_SPI_GPIO_OLD)            += spi_gpio_old.o
+ obj-$(CONFIG_SPI_IMX)                 += spi_imx.o
+ obj-$(CONFIG_SPI_LM70_LLP)            += spi_lm70llp.o
++obj-$(CONFIG_SPI_PB44)                        += pb44_spi.o
+ obj-$(CONFIG_SPI_PXA2XX)              += pxa2xx_spi.o
+ obj-$(CONFIG_SPI_OMAP_UWIRE)          += omap_uwire.o
+ obj-$(CONFIG_SPI_OMAP24XX)            += omap2_mcspi.o