ar71xx: add 4.1 support
[openwrt/openwrt.git] / target / linux / ar71xx / patches-4.1 / 500-MIPS-fw-myloader.patch
diff --git a/target/linux/ar71xx/patches-4.1/500-MIPS-fw-myloader.patch b/target/linux/ar71xx/patches-4.1/500-MIPS-fw-myloader.patch
new file mode 100644 (file)
index 0000000..2a89443
--- /dev/null
@@ -0,0 +1,22 @@
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -208,6 +208,7 @@ endif
+ #
+ libs-$(CONFIG_FW_ARC)         += arch/mips/fw/arc/
+ libs-$(CONFIG_FW_CFE)         += arch/mips/fw/cfe/
++libs-$(CONFIG_MYLOADER)               += arch/mips/fw/myloader/
+ libs-$(CONFIG_FW_SNIPROM)     += arch/mips/fw/sni/
+ libs-y                                += arch/mips/fw/lib/
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
+@@ -982,6 +982,9 @@ config MIPS_MSC
+ config MIPS_NILE4
+       bool
++config MYLOADER
++      bool
++
+ config SYNC_R4K
+       bool