arm64: Remove Vexpress Foundation support
[openwrt/openwrt.git] / target / linux / arm64 / image / Makefile
index cc04b183fc7ae5656edf96948db09347847c7c3a..d52936808deeca9c4be340ec815ba6c42e54dd82 100644 (file)
@@ -8,14 +8,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
 define Image/Prepare
-       -rm -rf $(KDIR)/linux-system.axf
        cp $(LINUX_DIR)/arch/$(LINUX_KARCH)/boot/Image $(KDIR)/Image
-       $(MAKE) -C boot-wrapper clean
-       $(MAKE) -C boot-wrapper compile
-endef
-
-define Build/Clean
-       $(MAKE) -C boot-wrapper clean
 endef
 
 define Image/Build/QemuVirt
@@ -25,13 +18,8 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
 endif
 endef
 
-define Image/Build/VexpressFoundation
-       $(CP) $(KDIR)/linux-system.axf $(BIN_DIR)/$(IMG_PREFIX)-vexpress-foundation.axf
-endef
-
 define Image/BuildKernel
        $(call Image/Build/QemuVirt)
-       $(call Image/Build/VexpressFoundation)
 endef
 
 define Image/Build/squashfs